aboutsummaryrefslogtreecommitdiffstats
path: root/tools/flex
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-13 12:59:47 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-11-25 19:23:03 +0100
commit7ef38e42c8440a29d1dc721a9e6184b2e369bc2f (patch)
treec5499b3910cf8f16a3a01d66fad223bb9b34df18 /tools/flex
parent82b34c1f6082e15347b80ff0aa1040e5f309d382 (diff)
downloadupstream-7ef38e42c8440a29d1dc721a9e6184b2e369bc2f.tar.gz
upstream-7ef38e42c8440a29d1dc721a9e6184b2e369bc2f.tar.bz2
upstream-7ef38e42c8440a29d1dc721a9e6184b2e369bc2f.zip
flex: Add a lex symlink
Some packages like libpfring assume the presense of lex, which on some other systems is a symlink to flex but not all. Symlink flex to fix compilation. Arch Linux and Fedora do this as far as I know. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/flex')
-rw-r--r--tools/flex/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/flex/Makefile b/tools/flex/Makefile
index 1eff81f345..bb5aecbdfe 100644
--- a/tools/flex/Makefile
+++ b/tools/flex/Makefile
@@ -21,6 +21,11 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += --disable-shared
+define Host/Install
+ $(call Host/Install/Default)
+ $(LN) flex $(STAGING_DIR_HOST)/bin/lex
+endef
+
define Host/Clean
-$(MAKE) -C $(HOST_BUILD_DIR) uninstall
$(call Host/Clean/Default)