aboutsummaryrefslogtreecommitdiffstats
path: root/tools/coreutils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-09 12:21:15 +0100
committerFelix Fietkau <nbd@nbd.name>2017-11-09 12:35:06 +0100
commit6bcc1c5331c797004e1b43168eb116d2d14b0102 (patch)
tree5e0238ef7f3e3502694ae664cf7694638a6d206a /tools/coreutils
parentb2aa820b48add74b97e0eab993ede648c43e85db (diff)
downloadupstream-6bcc1c5331c797004e1b43168eb116d2d14b0102.tar.gz
upstream-6bcc1c5331c797004e1b43168eb116d2d14b0102.tar.bz2
upstream-6bcc1c5331c797004e1b43168eb116d2d14b0102.zip
tools/coreutils: install readlink
Parts of the build system use non-portable invocation of readlink Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/coreutils')
-rw-r--r--tools/coreutils/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/coreutils/Makefile b/tools/coreutils/Makefile
index 1acdfb9160..c731eafda6 100644
--- a/tools/coreutils/Makefile
+++ b/tools/coreutils/Makefile
@@ -15,14 +15,14 @@ PKG_HASH:=8891d349ee87b9ff7870f52b6d9312a9db672d2439d289bc57084771ca21656b
HOST_BUILD_PARALLEL := 1
-BUILD_PROGRAMS = date
+BUILD_PROGRAMS = date readlink
include $(INCLUDE_DIR)/host-build.mk
BUILD_BINS = $(patsubst %,src/%,$(BUILD_PROGRAMS))
HOST_CONFIGURE_ARGS += \
- --enable-install-program=date
+ --enable-install-program=$(subst $(space),$(comma),$(strip $(BUILD_PROGRAMS)))
HOST_MAKE_FLAGS += \
PROGRAMS="$(BUILD_BINS)" \