aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-12 14:32:02 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-13 10:23:43 +0100
commit796977010078c3ed4c2c1ff00e36d815b8c45aa0 (patch)
tree28cf2fc08fe301e7559207cf43d13315be5355bd /tools/cmake
parentd6de31310cc1924ff077f4f143efa6496e3323aa (diff)
downloadupstream-796977010078c3ed4c2c1ff00e36d815b8c45aa0.tar.gz
upstream-796977010078c3ed4c2c1ff00e36d815b8c45aa0.tar.bz2
upstream-796977010078c3ed4c2c1ff00e36d815b8c45aa0.zip
cmake: support verbose build that shows compiler commands
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index c56cd40fb5..08e5a69ecf 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -29,4 +29,8 @@ HOST_CONFIGURE_VARS :=
HOST_CONFIGURE_ARGS := \
--prefix=$(STAGING_DIR_HOST)
+ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
+ HOST_MAKE_FLAGS += VERBOSE=1
+endif
+
$(eval $(call HostBuild))