aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-12 14:41:01 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-13 10:23:43 +0100
commit6f9011f089981776970ca3fb397c483e257f9dde (patch)
tree347195a7a79975e5bd17a85dc9480682698679f5 /tools/cmake
parent796977010078c3ed4c2c1ff00e36d815b8c45aa0 (diff)
downloadupstream-6f9011f089981776970ca3fb397c483e257f9dde.tar.gz
upstream-6f9011f089981776970ca3fb397c483e257f9dde.tar.bz2
upstream-6f9011f089981776970ca3fb397c483e257f9dde.zip
cmake: properly pass host cflags/ldflags to the build
This should hopefully fix build issues where libraries that we ship in tools/ were accidentally picked up from other places on the system, e.g. /usr/local Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index 08e5a69ecf..f3712391a6 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -24,7 +24,8 @@ HOST_CONFIGURE_CMD := \
$(BASH) ./configure \
$(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)")
-HOST_CONFIGURE_VARS :=
+HOST_CONFIGURE_VARS += \
+ CXXFLAGS="$(HOST_CFLAGS)"
HOST_CONFIGURE_ARGS := \
--prefix=$(STAGING_DIR_HOST)