aboutsummaryrefslogtreecommitdiffstats
path: root/tools/autoconf-archive
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2020-04-29 12:47:58 +0200
committerPetr Štetiar <ynezz@true.cz>2020-05-20 15:37:16 +0200
commit3c1d1d4332c7fbaccea01b92b28f6d96f7222492 (patch)
tree77dbca603838ffa2cacc279a0358a77f2fdb5792 /tools/autoconf-archive
parent1b2fefb244d7d2fd949104e743ff15d01bbe5bb0 (diff)
downloadupstream-3c1d1d4332c7fbaccea01b92b28f6d96f7222492.tar.gz
upstream-3c1d1d4332c7fbaccea01b92b28f6d96f7222492.tar.bz2
upstream-3c1d1d4332c7fbaccea01b92b28f6d96f7222492.zip
tools: add autoconf-archive
Some autotools based build systems are using autoconf-archive scripts and are expecting them to almost always be available. This is not required for regular releases as tar balls generated for releases commonly have existing configure script. This is rather intended to be used with autotools.mk's autoreconf and in cases it is not always possible to get release tar ball. Including this adds little to no overhead in terms of build time as those are just m4 scripts copied to an appropriate location. Signed-off-by: Karel Kočí <karel.koci@nic.cz> [fixed From: to match SoB] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'tools/autoconf-archive')
-rw-r--r--tools/autoconf-archive/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/autoconf-archive/Makefile b/tools/autoconf-archive/Makefile
new file mode 100644
index 0000000000..b3d729f41d
--- /dev/null
+++ b/tools/autoconf-archive/Makefile
@@ -0,0 +1,28 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=autoconf-archive
+PKG_VERSION:=2019.01.06
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/autoconf-archive
+PKG_HASH:=17195c833098da79de5778ee90948f4c5d90ed1a0cf8391b4ab348e2ec511e3f
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+ --datarootdir=$(STAGING_DIR_HOST)/share
+
+define Host/Compile
+ export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)
+endef
+
+define Host/Install
+ export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+define Host/Clean
+ -export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))