aboutsummaryrefslogtreecommitdiffstats
path: root/tools/autoconf-archive/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/autoconf-archive/Makefile')
-rw-r--r--tools/autoconf-archive/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/autoconf-archive/Makefile b/tools/autoconf-archive/Makefile
new file mode 100644
index 0000000000..b3d729f41d
--- /dev/null
+++ b/tools/autoconf-archive/Makefile
@@ -0,0 +1,28 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=autoconf-archive
+PKG_VERSION:=2019.01.06
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/autoconf-archive
+PKG_HASH:=17195c833098da79de5778ee90948f4c5d90ed1a0cf8391b4ab348e2ec511e3f
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+ --datarootdir=$(STAGING_DIR_HOST)/share
+
+define Host/Compile
+ export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)
+endef
+
+define Host/Install
+ export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+define Host/Clean
+ -export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))