aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-10-14 16:42:45 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-10-14 16:47:15 +0200
commit759f111f8d7f2d9f5f12713fc6f48ce6422997ec (patch)
tree6509a8d142669fe5c3ef2afe3365f9c33f234c69 /tools/Makefile
parent07e8c217cb79a19c59fcb34ea6de39aa91a625b6 (diff)
downloadupstream-759f111f8d7f2d9f5f12713fc6f48ce6422997ec.tar.gz
upstream-759f111f8d7f2d9f5f12713fc6f48ce6422997ec.tar.bz2
upstream-759f111f8d7f2d9f5f12713fc6f48ce6422997ec.zip
tools: patch: Fix build by not modifing Makefile.am
A new test case was adding in one of the patches fixing a problem, this also included a change in the test/Makefile.am to add this test case. The build system detected a change in the Makefile.am and wants to regenerate the Makefile.in, but this fails because automake-1.15 is not installed yet. As automake depends on patch being build first, make sure we do not modify the Makefile.am. This fixes build problem seen by the build bots. Fixes: 4797dddfde6 ("patch: apply upstream cve fixes") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile1
1 files changed, 0 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 7d6a17e926..9a354f6c70 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -67,7 +67,6 @@ $(curdir)/bc/compile := $(curdir)/bison/compile
$(curdir)/findutils/compile := $(curdir)/bison/compile
$(curdir)/gengetopt/compile := $(curdir)/libtool/compile
$(curdir)/patchelf/compile := $(curdir)/libtool/compile
-$(curdir)/patch/compile := $(curdir)/automake/compile
$(curdir)/dosfstools/compile := $(curdir)/autoconf/compile $(curdir)/automake/compile
$(curdir)/libressl/compile := $(curdir)/pkg-config/compile
$(curdir)/mkimage/compile += $(curdir)/libressl/compile