aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-10-14 15:25:37 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-10-14 15:27:38 +0200
commit07e8c217cb79a19c59fcb34ea6de39aa91a625b6 (patch)
treeb04d20a5a358e3dfb983886d23bb75242ebcb6cb /tools/Makefile
parent4797dddfde6a8ffdbdcb4e5b5e137b0a00313f62 (diff)
downloadupstream-07e8c217cb79a19c59fcb34ea6de39aa91a625b6.tar.gz
upstream-07e8c217cb79a19c59fcb34ea6de39aa91a625b6.tar.bz2
upstream-07e8c217cb79a19c59fcb34ea6de39aa91a625b6.zip
tools: patch: make patch build depend on automake
The Makefile.am changed and now patch wants to use automake to regenerate the Makefile.in. Make sure automake was build before we build patch. This fixes build problem seen by the build bots. Fixes: 4797dddfde6 ("patch: apply upstream cve fixes") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 9a354f6c70..7d6a17e926 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -67,6 +67,7 @@ $(curdir)/bc/compile := $(curdir)/bison/compile
$(curdir)/findutils/compile := $(curdir)/bison/compile
$(curdir)/gengetopt/compile := $(curdir)/libtool/compile
$(curdir)/patchelf/compile := $(curdir)/libtool/compile
+$(curdir)/patch/compile := $(curdir)/automake/compile
$(curdir)/dosfstools/compile := $(curdir)/autoconf/compile $(curdir)/automake/compile
$(curdir)/libressl/compile := $(curdir)/pkg-config/compile
$(curdir)/mkimage/compile += $(curdir)/libressl/compile