aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2019-11-01 10:18:30 +0100
committerJohn Crispin <john@phrozen.org>2019-11-02 20:51:56 +0100
commit1f0063b58c84e55e209d19007d2acfbfdd22bc33 (patch)
treec7a311c61d3e64f4144f4ee292eee6c27a8ac11d /tools/Makefile
parent999504ff65a24baf9e022883a63e2e862e0b6aae (diff)
downloadupstream-1f0063b58c84e55e209d19007d2acfbfdd22bc33.tar.gz
upstream-1f0063b58c84e55e209d19007d2acfbfdd22bc33.tar.bz2
upstream-1f0063b58c84e55e209d19007d2acfbfdd22bc33.zip
rules.mk: remove "$(STAGING_DIR)/include"
"$(STAGING_DIR)/include" was carried over from buildroot-ng to OpenWrt in commit 60c1f0f64d23003a19a07d6b9638542130f6641d. buildroot has dropped this directory a long time ago. In OpenWrt the directory is still created by the PrepareStaging macro and is part of the default TARGET_CPPFLAGS. But nothing at all installs headers into this directory, nor should anything be installed under this path. Removing this directory from TARGET_CPPFLAGS will cut down the log noise a bit. Not only will CPPFLAGS be shorter, there will be less warnings set off by "-Wmissing-include-dirs" (or even failures when paired with "-Werror"). After all the directory does not even _exist_ in the SDKs, which are used on the build bots when building packages (see [1] and [2]). make[8]: Entering directory '/builder/shared-workdir/build/sdk/build_dir/target-aarch64_generic_musl/libmbim-1.20.0/src/common' CC libmbim_common_la-mbim-common.lo cc1: error: /builder/shared-workdir/build/sdk/staging_dir/target-aarch64_generic_musl/include: No such file or directory [-Werror=missing-include-dirs] cc1: all warnings being treated as errors [1] https://github.com/openwrt/packages/issues/10377 [2] https://github.com/openwrt/packages/pull/10378 Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net> Acked-by: Jo-Philipp Wich <jo@mein.io> Acked-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 23671cba91..2f57d25525 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -123,7 +123,7 @@ define PrepareStaging
$(if $(QUIET),,set -x;) \
mkdir -p "$$dir"; \
cd "$$dir"; \
- mkdir -p bin lib include stamp; \
+ mkdir -p bin lib stamp; \
); done
endef