aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-16 16:08:44 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-17 10:36:52 +0100
commit180e93ba8b1b72a80d05c59497f63f28728f17ce (patch)
tree1c4a9b06213b57ecc59cc8620ad0e42c26a04504 /tools/Makefile
parentd49059693b752f6bca398073c1f0d0908e3d9b80 (diff)
downloadupstream-180e93ba8b1b72a80d05c59497f63f28728f17ce.tar.gz
upstream-180e93ba8b1b72a80d05c59497f63f28728f17ce.tar.bz2
upstream-180e93ba8b1b72a80d05c59497f63f28728f17ce.zip
build: add CHECK_ALL variable to allow make download/check to include not selected packages
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 6915ea7a05..247f55776f 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -110,6 +110,11 @@ tools-y += flock
$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
$(curdir)/builddirs-default := $(tools-y)
+ifdef CHECK_ALL
+$(curdir)/builddirs-check:=$($(curdir)/builddirs)
+$(curdir)/builddirs-download:=$($(curdir)/builddirs)
+endif
+
ifndef DUMP_TARGET_DB
define PrepareStaging
@for dir in $(1); do ( \