aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-16 16:08:44 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-17 10:36:52 +0100
commit180e93ba8b1b72a80d05c59497f63f28728f17ce (patch)
tree1c4a9b06213b57ecc59cc8620ad0e42c26a04504
parentd49059693b752f6bca398073c1f0d0908e3d9b80 (diff)
downloadupstream-180e93ba8b1b72a80d05c59497f63f28728f17ce.tar.gz
upstream-180e93ba8b1b72a80d05c59497f63f28728f17ce.tar.bz2
upstream-180e93ba8b1b72a80d05c59497f63f28728f17ce.zip
build: add CHECK_ALL variable to allow make download/check to include not selected packages
Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--package/Makefile4
-rw-r--r--tools/Makefile5
2 files changed, 9 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index c4fb8ca974..64efeb3745 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -14,6 +14,10 @@ $(curdir)/builddirs:=$(sort $(package-) $(package-y) $(package-m))
$(curdir)/builddirs-install:=.
$(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
$(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
+ifdef CHECK_ALL
+$(curdir)/builddirs-check:=$($(curdir)/builddirs)
+$(curdir)/builddirs-download:=$($(curdir)/builddirs)
+endif
ifneq ($(IGNORE_ERRORS),)
package-y-filter := $(package-y)
package-m-filter := $(filter-out $(package-y),$(package-m))
diff --git a/tools/Makefile b/tools/Makefile
index 6915ea7a05..247f55776f 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -110,6 +110,11 @@ tools-y += flock
$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
$(curdir)/builddirs-default := $(tools-y)
+ifdef CHECK_ALL
+$(curdir)/builddirs-check:=$($(curdir)/builddirs)
+$(curdir)/builddirs-download:=$($(curdir)/builddirs)
+endif
+
ifndef DUMP_TARGET_DB
define PrepareStaging
@for dir in $(1); do ( \