aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorYorkie Liu <yorkiefixer@gmail.com>2019-11-19 13:41:10 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2019-12-23 00:04:18 +0100
commit65a561fd0919eafff2363ae8324db64be2a57f77 (patch)
treee2eff65bcbb44cdc940866e8e5322cd08da1feae /toolchain/gcc
parent77e27e0f5354e3155c9951a0d5e570e36d548f1c (diff)
downloadupstream-65a561fd0919eafff2363ae8324db64be2a57f77.tar.gz
upstream-65a561fd0919eafff2363ae8324db64be2a57f77.tar.bz2
upstream-65a561fd0919eafff2363ae8324db64be2a57f77.zip
toolchain/gcc: correct the check expr for newer clang
This fixes gcc build error within clang 11.0, it tweaks the version string from LLVM to clang. Signed-off-by: Yorkie Liu <yorkiefixer@gmail.com>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 8ce8d84a5f..24c923abef 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -89,7 +89,7 @@ endif
GCC_CONFIGURE:= \
SHELL="$(BASH)" \
- $(if $(shell gcc --version 2>&1 | grep LLVM), \
+ $(if $(shell gcc --version 2>&1 | grep -E "Apple.(LLVM|clang)"), \
CFLAGS="-O2 -fbracket-depth=512 -pipe" \
CXXFLAGS="-O2 -fbracket-depth=512 -pipe" \
) \