aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2019-02-23 01:45:42 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-26 23:20:04 +0100
commit40aec89b4c827f8c6f8d44ca44d43434c22fbafb (patch)
treefc2e35deccbe77850285cee40f30dbc70d9d5305 /toolchain/gcc
parent700c0edc06f738fe22a4cd92cbaa52e9f798a60c (diff)
downloadupstream-40aec89b4c827f8c6f8d44ca44d43434c22fbafb.tar.gz
upstream-40aec89b4c827f8c6f8d44ca44d43434c22fbafb.tar.bz2
upstream-40aec89b4c827f8c6f8d44ca44d43434c22fbafb.zip
toolchain: Update to GCC 8.3.0
Update GCC to 8.3.0 Refresh patches Allow GCC to be used for ARC Source: https://github.com/openwrt/openwrt/pull/1803#issuecomment-462334890 Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.in1
-rw-r--r--toolchain/gcc/Config.version2
-rw-r--r--toolchain/gcc/common.mk4
-rw-r--r--toolchain/gcc/patches/8.3.0/002-case_insensitive.patch (renamed from toolchain/gcc/patches/8.2.0/002-case_insensitive.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/010-documentation.patch (renamed from toolchain/gcc/patches/8.2.0/010-documentation.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/110-Fix-MIPS-PR-84790.patch (renamed from toolchain/gcc/patches/8.2.0/110-Fix-MIPS-PR-84790.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/230-musl_libssp.patch (renamed from toolchain/gcc/patches/8.2.0/230-musl_libssp.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/300-mips_Os_cpu_rtx_cost_model.patch (renamed from toolchain/gcc/patches/8.2.0/300-mips_Os_cpu_rtx_cost_model.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/800-arm_v5te_no_ldrd_strd.patch (renamed from toolchain/gcc/patches/8.2.0/800-arm_v5te_no_ldrd_strd.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/810-arm-softfloat-libgcc.patch (renamed from toolchain/gcc/patches/8.2.0/810-arm-softfloat-libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/820-libgcc_pic.patch (renamed from toolchain/gcc/patches/8.2.0/820-libgcc_pic.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/840-armv4_pass_fix-v4bx_to_ld.patch (renamed from toolchain/gcc/patches/8.2.0/840-armv4_pass_fix-v4bx_to_ld.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/850-use_shared_libgcc.patch (renamed from toolchain/gcc/patches/8.2.0/850-use_shared_libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/851-libgcc_no_compat.patch (renamed from toolchain/gcc/patches/8.2.0/851-libgcc_no_compat.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/870-ppc_no_crtsavres.patch (renamed from toolchain/gcc/patches/8.2.0/870-ppc_no_crtsavres.patch)2
-rw-r--r--toolchain/gcc/patches/8.3.0/881-no_tm_section.patch (renamed from toolchain/gcc/patches/8.2.0/881-no_tm_section.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/900-bad-mips16-crt.patch (renamed from toolchain/gcc/patches/8.2.0/900-bad-mips16-crt.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/910-mbsd_multi.patch (renamed from toolchain/gcc/patches/8.2.0/910-mbsd_multi.patch)4
-rw-r--r--toolchain/gcc/patches/8.3.0/920-specs_nonfatal_getenv.patch (renamed from toolchain/gcc/patches/8.2.0/920-specs_nonfatal_getenv.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/930-fix-mips-noexecstack.patch (renamed from toolchain/gcc/patches/8.2.0/930-fix-mips-noexecstack.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/931-libffi-fix-MIPS-softfloat-build-issue.patch (renamed from toolchain/gcc/patches/8.2.0/931-libffi-fix-MIPS-softfloat-build-issue.patch)0
-rw-r--r--toolchain/gcc/patches/8.3.0/960-gotools-fix-compilation-when-making-cross-compiler.patch (renamed from toolchain/gcc/patches/8.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch)0
22 files changed, 6 insertions, 7 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index c3208d372c..d85e8cd402 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -22,7 +22,6 @@ choice
config GCC_USE_VERSION_8
bool "gcc 8.x"
- depends on !arc
endchoice
config GCC_USE_GRAPHITE
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index 9bfe1b8aaf..ff574fffcd 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -19,5 +19,5 @@ config GCC_VERSION
string
default "5.5.0" if GCC_VERSION_5
default "arc-2017.09-release" if GCC_VERSION_7_1_ARC
- default "8.2.0" if GCC_VERSION_8
+ default "8.3.0" if GCC_VERSION_8
default "7.4.0"
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 2a6d75d0dd..e0ee5ac56a 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -36,8 +36,8 @@ ifeq ($(PKG_VERSION),7.4.0)
PKG_HASH:=eddde28d04f334aec1604456e536416549e9b1aa137fc69204e65eb0c009fe51
endif
-ifeq ($(PKG_VERSION),8.2.0)
- PKG_HASH:=196c3c04ba2613f893283977e6011b2345d1cd1af9abeac58e916b1aab3e0080
+ifeq ($(PKG_VERSION),8.3.0)
+ PKG_HASH:=64baadfe6cc0f4947a84cb12d7f0dfaf45bb58b7e92461639596c21e02d97d2c
endif
ifneq ($(CONFIG_GCC_VERSION_7_1_ARC),)
diff --git a/toolchain/gcc/patches/8.2.0/002-case_insensitive.patch b/toolchain/gcc/patches/8.3.0/002-case_insensitive.patch
index 3442076d7d..3442076d7d 100644
--- a/toolchain/gcc/patches/8.2.0/002-case_insensitive.patch
+++ b/toolchain/gcc/patches/8.3.0/002-case_insensitive.patch
diff --git a/toolchain/gcc/patches/8.2.0/010-documentation.patch b/toolchain/gcc/patches/8.3.0/010-documentation.patch
index c3a6a15901..c3a6a15901 100644
--- a/toolchain/gcc/patches/8.2.0/010-documentation.patch
+++ b/toolchain/gcc/patches/8.3.0/010-documentation.patch
diff --git a/toolchain/gcc/patches/8.2.0/110-Fix-MIPS-PR-84790.patch b/toolchain/gcc/patches/8.3.0/110-Fix-MIPS-PR-84790.patch
index b89eca2faf..b89eca2faf 100644
--- a/toolchain/gcc/patches/8.2.0/110-Fix-MIPS-PR-84790.patch
+++ b/toolchain/gcc/patches/8.3.0/110-Fix-MIPS-PR-84790.patch
diff --git a/toolchain/gcc/patches/8.2.0/230-musl_libssp.patch b/toolchain/gcc/patches/8.3.0/230-musl_libssp.patch
index b3ab79cafb..b3ab79cafb 100644
--- a/toolchain/gcc/patches/8.2.0/230-musl_libssp.patch
+++ b/toolchain/gcc/patches/8.3.0/230-musl_libssp.patch
diff --git a/toolchain/gcc/patches/8.2.0/300-mips_Os_cpu_rtx_cost_model.patch b/toolchain/gcc/patches/8.3.0/300-mips_Os_cpu_rtx_cost_model.patch
index 6f97356ac6..6f97356ac6 100644
--- a/toolchain/gcc/patches/8.2.0/300-mips_Os_cpu_rtx_cost_model.patch
+++ b/toolchain/gcc/patches/8.3.0/300-mips_Os_cpu_rtx_cost_model.patch
diff --git a/toolchain/gcc/patches/8.2.0/800-arm_v5te_no_ldrd_strd.patch b/toolchain/gcc/patches/8.3.0/800-arm_v5te_no_ldrd_strd.patch
index 172295f28b..172295f28b 100644
--- a/toolchain/gcc/patches/8.2.0/800-arm_v5te_no_ldrd_strd.patch
+++ b/toolchain/gcc/patches/8.3.0/800-arm_v5te_no_ldrd_strd.patch
diff --git a/toolchain/gcc/patches/8.2.0/810-arm-softfloat-libgcc.patch b/toolchain/gcc/patches/8.3.0/810-arm-softfloat-libgcc.patch
index 5c9d86aead..5c9d86aead 100644
--- a/toolchain/gcc/patches/8.2.0/810-arm-softfloat-libgcc.patch
+++ b/toolchain/gcc/patches/8.3.0/810-arm-softfloat-libgcc.patch
diff --git a/toolchain/gcc/patches/8.2.0/820-libgcc_pic.patch b/toolchain/gcc/patches/8.3.0/820-libgcc_pic.patch
index 1a9678d480..1a9678d480 100644
--- a/toolchain/gcc/patches/8.2.0/820-libgcc_pic.patch
+++ b/toolchain/gcc/patches/8.3.0/820-libgcc_pic.patch
diff --git a/toolchain/gcc/patches/8.2.0/840-armv4_pass_fix-v4bx_to_ld.patch b/toolchain/gcc/patches/8.3.0/840-armv4_pass_fix-v4bx_to_ld.patch
index b9c9b161ad..b9c9b161ad 100644
--- a/toolchain/gcc/patches/8.2.0/840-armv4_pass_fix-v4bx_to_ld.patch
+++ b/toolchain/gcc/patches/8.3.0/840-armv4_pass_fix-v4bx_to_ld.patch
diff --git a/toolchain/gcc/patches/8.2.0/850-use_shared_libgcc.patch b/toolchain/gcc/patches/8.3.0/850-use_shared_libgcc.patch
index f619f0e6a1..f619f0e6a1 100644
--- a/toolchain/gcc/patches/8.2.0/850-use_shared_libgcc.patch
+++ b/toolchain/gcc/patches/8.3.0/850-use_shared_libgcc.patch
diff --git a/toolchain/gcc/patches/8.2.0/851-libgcc_no_compat.patch b/toolchain/gcc/patches/8.3.0/851-libgcc_no_compat.patch
index d710e40717..d710e40717 100644
--- a/toolchain/gcc/patches/8.2.0/851-libgcc_no_compat.patch
+++ b/toolchain/gcc/patches/8.3.0/851-libgcc_no_compat.patch
diff --git a/toolchain/gcc/patches/8.2.0/870-ppc_no_crtsavres.patch b/toolchain/gcc/patches/8.3.0/870-ppc_no_crtsavres.patch
index ecaf75a476..2aa4b8e373 100644
--- a/toolchain/gcc/patches/8.2.0/870-ppc_no_crtsavres.patch
+++ b/toolchain/gcc/patches/8.3.0/870-ppc_no_crtsavres.patch
@@ -1,6 +1,6 @@
--- a/gcc/config/rs6000/rs6000.c
+++ b/gcc/config/rs6000/rs6000.c
-@@ -24501,7 +24501,7 @@ rs6000_savres_strategy (rs6000_stack_t *
+@@ -24632,7 +24632,7 @@ rs6000_savres_strategy (rs6000_stack_t *
/* Define cutoff for using out-of-line functions to save registers. */
if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
{
diff --git a/toolchain/gcc/patches/8.2.0/881-no_tm_section.patch b/toolchain/gcc/patches/8.3.0/881-no_tm_section.patch
index fab5db3be5..fab5db3be5 100644
--- a/toolchain/gcc/patches/8.2.0/881-no_tm_section.patch
+++ b/toolchain/gcc/patches/8.3.0/881-no_tm_section.patch
diff --git a/toolchain/gcc/patches/8.2.0/900-bad-mips16-crt.patch b/toolchain/gcc/patches/8.3.0/900-bad-mips16-crt.patch
index dd6e9dc889..dd6e9dc889 100644
--- a/toolchain/gcc/patches/8.2.0/900-bad-mips16-crt.patch
+++ b/toolchain/gcc/patches/8.3.0/900-bad-mips16-crt.patch
diff --git a/toolchain/gcc/patches/8.2.0/910-mbsd_multi.patch b/toolchain/gcc/patches/8.3.0/910-mbsd_multi.patch
index d9802b6d61..fb8e25cb18 100644
--- a/toolchain/gcc/patches/8.2.0/910-mbsd_multi.patch
+++ b/toolchain/gcc/patches/8.3.0/910-mbsd_multi.patch
@@ -114,7 +114,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
; On SVR4 targets, it also controls whether or not to emit a
--- a/gcc/opts.c
+++ b/gcc/opts.c
-@@ -2056,6 +2056,9 @@ common_handle_option (struct gcc_options
+@@ -2065,6 +2065,9 @@ common_handle_option (struct gcc_options
opts, opts_set, loc, dc);
break;
@@ -126,7 +126,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
opts->x_warn_larger_than = value != -1;
--- a/gcc/doc/invoke.texi
+++ b/gcc/doc/invoke.texi
-@@ -7012,6 +7012,17 @@ This option is only supported for C and
+@@ -7014,6 +7014,17 @@ This option is only supported for C and
@option{-Wall} and by @option{-Wpedantic}, which can be disabled with
@option{-Wno-pointer-sign}.
diff --git a/toolchain/gcc/patches/8.2.0/920-specs_nonfatal_getenv.patch b/toolchain/gcc/patches/8.3.0/920-specs_nonfatal_getenv.patch
index c3836e63af..c3836e63af 100644
--- a/toolchain/gcc/patches/8.2.0/920-specs_nonfatal_getenv.patch
+++ b/toolchain/gcc/patches/8.3.0/920-specs_nonfatal_getenv.patch
diff --git a/toolchain/gcc/patches/8.2.0/930-fix-mips-noexecstack.patch b/toolchain/gcc/patches/8.3.0/930-fix-mips-noexecstack.patch
index 706d67f7c9..706d67f7c9 100644
--- a/toolchain/gcc/patches/8.2.0/930-fix-mips-noexecstack.patch
+++ b/toolchain/gcc/patches/8.3.0/930-fix-mips-noexecstack.patch
diff --git a/toolchain/gcc/patches/8.2.0/931-libffi-fix-MIPS-softfloat-build-issue.patch b/toolchain/gcc/patches/8.3.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
index fb4cb1533a..fb4cb1533a 100644
--- a/toolchain/gcc/patches/8.2.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
+++ b/toolchain/gcc/patches/8.3.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
diff --git a/toolchain/gcc/patches/8.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch b/toolchain/gcc/patches/8.3.0/960-gotools-fix-compilation-when-making-cross-compiler.patch
index 1dd05080d3..1dd05080d3 100644
--- a/toolchain/gcc/patches/8.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch
+++ b/toolchain/gcc/patches/8.3.0/960-gotools-fix-compilation-when-making-cross-compiler.patch