aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2019-02-23 10:47:54 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-26 23:20:04 +0100
commit700c0edc06f738fe22a4cd92cbaa52e9f798a60c (patch)
treed663638a866aec87cfc33da7d2f4526bcdb178cb /toolchain/gcc
parent38867b7ebafd8fbbbf3ff400e5a241ae88dfedab (diff)
downloadupstream-700c0edc06f738fe22a4cd92cbaa52e9f798a60c.tar.gz
upstream-700c0edc06f738fe22a4cd92cbaa52e9f798a60c.tar.bz2
upstream-700c0edc06f738fe22a4cd92cbaa52e9f798a60c.zip
toolchain/gcc: Remove workaround for GCC 4.8
GCC 4.8 was removed a long time ago... Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index b75fce57ef..2a6d75d0dd 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -123,15 +123,12 @@ GCC_CONFIGURE:= \
--with-gmp=$(TOPDIR)/staging_dir/host \
--with-mpfr=$(TOPDIR)/staging_dir/host \
--with-mpc=$(TOPDIR)/staging_dir/host \
- --disable-decimal-float
+ --disable-decimal-float \
+ --with-diagnostics-color=auto-if-env
ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
GCC_CONFIGURE += --with-mips-plt
endif
-ifndef GCC_VERSION_4_8
- GCC_CONFIGURE += --with-diagnostics-color=auto-if-env
-endif
-
ifneq ($(CONFIG_GCC_DEFAULT_PIE),)
GCC_CONFIGURE+= \
--enable-default-pie