aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-22 16:23:15 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-24 09:40:46 +0100
commit3f55e5aeb5ef269db8e64eea1b113cb6daf20327 (patch)
tree90a175947042a299f160e9f6fba13891e59e724d /toolchain/gcc
parent8bf69ee78cfefc0ee87d4a6820a907713e3bc1c3 (diff)
downloadupstream-3f55e5aeb5ef269db8e64eea1b113cb6daf20327.tar.gz
upstream-3f55e5aeb5ef269db8e64eea1b113cb6daf20327.tar.bz2
upstream-3f55e5aeb5ef269db8e64eea1b113cb6daf20327.zip
toolchain: remove ppl/cloog, disable graphite for gcc 4.8
graphite is disabled by default and it's not worth carrying ppl and cloog for supporting this feature on the old gcc 4.8, which is only used for ARC Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.in7
-rw-r--r--toolchain/gcc/common.mk6
2 files changed, 2 insertions, 11 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 41ea61cb8a..34c597c9e0 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -23,15 +23,10 @@ choice
endchoice
config GCC_USE_GRAPHITE
+ depends on !GCC_VERSION_4_8_ARC
bool
prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
-config GCC_USE_SYSTEM_PPL_CLOOG
- bool
- prompt "Use the system versions of PPL and CLooG"
- depends on GCC_USE_GRAPHITE && GCC_VERSION_4_8
- default n
-
config EXTRA_GCC_CONFIG_OPTIONS
string
prompt "Additional gcc configure options" if TOOLCHAINOPTS
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 37c228e4a6..c1010dd0c9 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -80,11 +80,7 @@ ifdef CONFIG_INSTALL_GCCGO
endif
ifdef CONFIG_GCC_USE_GRAPHITE
- ifdef CONFIG_GCC_VERSION_4_8
- GRAPHITE_CONFIGURE=--with-cloog=$(REAL_STAGING_DIR_HOST)
- else
- GRAPHITE_CONFIGURE=--with-isl=$(REAL_STAGING_DIR_HOST)
- endif
+ GRAPHITE_CONFIGURE=--with-isl=$(REAL_STAGING_DIR_HOST)
else
GRAPHITE_CONFIGURE=--without-isl --without-cloog
endif