aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--toolchain/gcc/Config.in7
-rw-r--r--toolchain/gcc/common.mk6
-rw-r--r--tools/Makefile12
-rw-r--r--tools/cloog/Makefile41
-rw-r--r--tools/ppl/Makefile37
-rw-r--r--tools/ppl/patches/001-disable-serial-tests.patch44
6 files changed, 3 insertions, 144 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 41ea61cb8a..34c597c9e0 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -23,15 +23,10 @@ choice
endchoice
config GCC_USE_GRAPHITE
+ depends on !GCC_VERSION_4_8_ARC
bool
prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
-config GCC_USE_SYSTEM_PPL_CLOOG
- bool
- prompt "Use the system versions of PPL and CLooG"
- depends on GCC_USE_GRAPHITE && GCC_VERSION_4_8
- default n
-
config EXTRA_GCC_CONFIG_OPTIONS
string
prompt "Additional gcc configure options" if TOOLCHAINOPTS
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 37c228e4a6..c1010dd0c9 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -80,11 +80,7 @@ ifdef CONFIG_INSTALL_GCCGO
endif
ifdef CONFIG_GCC_USE_GRAPHITE
- ifdef CONFIG_GCC_VERSION_4_8
- GRAPHITE_CONFIGURE=--with-cloog=$(REAL_STAGING_DIR_HOST)
- else
- GRAPHITE_CONFIGURE=--with-isl=$(REAL_STAGING_DIR_HOST)
- endif
+ GRAPHITE_CONFIGURE=--with-isl=$(REAL_STAGING_DIR_HOST)
else
GRAPHITE_CONFIGURE=--without-isl --without-cloog
endif
diff --git a/tools/Makefile b/tools/Makefile
index 247f55776f..5f4174e523 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -14,13 +14,7 @@ tools-y :=
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
BUILD_TOOLCHAIN := y
ifdef CONFIG_GCC_USE_GRAPHITE
- ifneq ($(CONFIG_GCC_VERSION_4_8),)
- ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
- BUILD_PPL_CLOOG = y
- endif
- else
- BUILD_ISL = y
- endif
+ BUILD_ISL = y
endif
endif
ifneq ($(CONFIG_SDK)$(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_b43legacy-firmware)$(CONFIG_BRCMSMAC_USE_FW_FROM_WL),)
@@ -41,7 +35,6 @@ tools-$(CONFIG_TARGET_ar71xx) += lzma-old squashfs
tools-$(CONFIG_USES_MINOR) += kernel2minor
tools-y += lzma squashfs4
tools-$(BUILD_B43_TOOLS) += b43-tools
-tools-$(BUILD_PPL_CLOOG) += ppl cloog
tools-$(BUILD_ISL) += isl
tools-$(CONFIG_USE_SPARSE) += sparse
tools-$(CONFIG_TARGET_apm821xx) += genext2fs
@@ -59,8 +52,6 @@ $(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install $(
$(curdir)/gmp/compile := $(curdir)/libtool/install
$(curdir)/mpc/compile := $(curdir)/mpfr/install $(curdir)/gmp/install
$(curdir)/mpfr/compile := $(curdir)/gmp/install
-$(curdir)/ppl/compile := $(curdir)/gmp/install
-$(curdir)/cloog/compile := $(curdir)/ppl/install
$(curdir)/mtd-utils/compile := $(curdir)/e2fsprogs/install $(curdir)/xz/install
$(curdir)/mkimage/compile := $(curdir)/sed/install
$(curdir)/mklibs/compile := $(curdir)/libtool/install
@@ -73,7 +64,6 @@ $(curdir)/libelf/compile := $(curdir)/libtool/install
$(curdir)/sdcc/compile := $(curdir)/bison/install
$(curdir)/b43-tools/compile := $(curdir)/bison/install
$(curdir)/padjffs2/compile := $(curdir)/findutils/install
-$(curdir)/cloog/compile := $(curdir)/ppl/install
$(curdir)/isl/compile := $(curdir)/gmp/install
$(curdir)/bc/compile := $(curdir)/bison/install
$(curdir)/findutils/compile := $(curdir)/bison/install
diff --git a/tools/cloog/Makefile b/tools/cloog/Makefile
deleted file mode 100644
index f392e0546e..0000000000
--- a/tools/cloog/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-# Copyright (C) 2009-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=cloog
-PKG_VERSION:=0.18.1
-
-PKG_SOURCE_URL:=http://www.bastoul.net/cloog/pages/download/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=02500a4edd14875f94fe84cbeda4290425cb0c1c2474c6f75d75a303d64b4196
-
-HOST_FIXUP:=autoreconf
-
-HOST_BUILD_PARALLEL:=1
-HOST_CONFIGURE_PARALLEL:=1
-
-include $(INCLUDE_DIR)/host-build.mk
-
-unexport CFLAGS
-
-HOST_CONFIGURE_VARS += \
- LIBS=-lstdc++
-
-HOST_CONFIGURE_ARGS += \
- --enable-static \
- --disable-shared \
- --with-ppl=$(BUILD_DIR_HOST)
-
-define Host/Configure
- (cd $(HOST_BUILD_DIR)/$(3); \
- $(HOST_CONFIGURE_CMD) \
- $(HOST_CONFIGURE_VARS) \
- $(HOST_CONFIGURE_ARGS); \
- )
-endef
-
-$(eval $(call HostBuild))
diff --git a/tools/ppl/Makefile b/tools/ppl/Makefile
deleted file mode 100644
index 04a4f69a38..0000000000
--- a/tools/ppl/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-#
-# Copyright (C) 2009-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ppl
-PKG_VERSION:=1.2
-
-PKG_SOURCE_URL:=http://bugseng.com/products/ppl/download/ftp/releases/$(PKG_VERSION)/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=691f0d5a4fb0e206f4e132fc9132c71d6e33cdda168470d40ac3cf62340e9a60
-
-HOST_FIXUP:=autoreconf
-
-HOST_BUILD_PARALLEL:=1
-HOST_CONFIGURE_PARALLEL:=1
-
-include $(INCLUDE_DIR)/host-build.mk
-
-unexport CFLAGS
-
-HOST_CONFIGURE_ARGS += \
- --enable-static \
- --disable-shared
-
-define Host/Configure
- (cd $(HOST_BUILD_DIR)/$(3); \
- $(HOST_CONFIGURE_CMD) \
- $(HOST_CONFIGURE_VARS) \
- $(HOST_CONFIGURE_ARGS); \
- )
-endef
-
-$(eval $(call HostBuild))
diff --git a/tools/ppl/patches/001-disable-serial-tests.patch b/tools/ppl/patches/001-disable-serial-tests.patch
deleted file mode 100644
index 91b0753feb..0000000000
--- a/tools/ppl/patches/001-disable-serial-tests.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/tests/BD_Shape/Makefile.am
-+++ b/tests/BD_Shape/Makefile.am
-@@ -21,8 +21,6 @@
- # For the most up-to-date information see the Parma Polyhedra Library
- # site: http://bugseng.com/products/ppl/ .
-
--AUTOMAKE_OPTIONS = serial-tests
--
- if VALGRIND_TESTS_ENABLED
-
- CHECKER = \
---- a/tests/Box/Makefile.am
-+++ b/tests/Box/Makefile.am
-@@ -21,8 +21,6 @@
- # For the most up-to-date information see the Parma Polyhedra Library
- # site: http://bugseng.com/products/ppl/ .
-
--AUTOMAKE_OPTIONS = serial-tests
--
- if VALGRIND_TESTS_ENABLED
-
- CHECKER = \
---- a/tests/Concrete_Expression/Makefile.am
-+++ b/tests/Concrete_Expression/Makefile.am
-@@ -21,8 +21,6 @@
- # For the most up-to-date information see the Parma Polyhedra Library
- # site: http://bugseng.com/products/ppl/ .
-
--AUTOMAKE_OPTIONS = serial-tests
--
- if VALGRIND_TESTS_ENABLED
-
- CHECKER = \
---- a/tests/Octagonal_Shape/Makefile.am
-+++ b/tests/Octagonal_Shape/Makefile.am
-@@ -21,8 +21,6 @@
- # For the most up-to-date information see the Parma Polyhedra Library
- # site: http://bugseng.com/products/ppl/ .
-
--AUTOMAKE_OPTIONS = serial-tests
--
- if VALGRIND_TESTS_ENABLED
-
- CHECKER = \