aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorSyrone Wong <wong.syrone@gmail.com>2018-07-27 18:32:03 +0800
committerFelix Fietkau <nbd@nbd.name>2018-08-20 09:24:33 +0200
commit2fb95f71425cc1b3cc9424bb2922fd296e4e05bf (patch)
tree99c4058eff16a718198be7a02ee14f457708496f /toolchain/gcc
parent713cee6463a8b654d2c72e469112130373c1336b (diff)
downloadupstream-2fb95f71425cc1b3cc9424bb2922fd296e4e05bf.tar.gz
upstream-2fb95f71425cc1b3cc9424bb2922fd296e4e05bf.tar.bz2
upstream-2fb95f71425cc1b3cc9424bb2922fd296e4e05bf.zip
toolchain/gcc: update 8.x to 8.2.0
This release fixes LTO link-time performance problems and C++ bug introduced in GCC 8.1 Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.version2
-rw-r--r--toolchain/gcc/common.mk4
-rw-r--r--toolchain/gcc/patches/8.2.0/002-case_insensitive.patch (renamed from toolchain/gcc/patches/8.1.0/002-case_insensitive.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/010-documentation.patch (renamed from toolchain/gcc/patches/8.1.0/010-documentation.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/110-Fix-MIPS-PR-84790.patch (renamed from toolchain/gcc/patches/8.1.0/110-Fix-MIPS-PR-84790.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/230-musl_libssp.patch (renamed from toolchain/gcc/patches/8.1.0/230-musl_libssp.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/300-mips_Os_cpu_rtx_cost_model.patch (renamed from toolchain/gcc/patches/8.1.0/300-mips_Os_cpu_rtx_cost_model.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/800-arm_v5te_no_ldrd_strd.patch (renamed from toolchain/gcc/patches/8.1.0/800-arm_v5te_no_ldrd_strd.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/810-arm-softfloat-libgcc.patch (renamed from toolchain/gcc/patches/8.1.0/810-arm-softfloat-libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/820-libgcc_pic.patch (renamed from toolchain/gcc/patches/8.1.0/820-libgcc_pic.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/840-armv4_pass_fix-v4bx_to_ld.patch (renamed from toolchain/gcc/patches/8.1.0/840-armv4_pass_fix-v4bx_to_ld.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/850-use_shared_libgcc.patch (renamed from toolchain/gcc/patches/8.1.0/850-use_shared_libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/851-libgcc_no_compat.patch (renamed from toolchain/gcc/patches/8.1.0/851-libgcc_no_compat.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/870-ppc_no_crtsavres.patch (renamed from toolchain/gcc/patches/8.1.0/870-ppc_no_crtsavres.patch)2
-rw-r--r--toolchain/gcc/patches/8.2.0/881-no_tm_section.patch (renamed from toolchain/gcc/patches/8.1.0/881-no_tm_section.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/900-bad-mips16-crt.patch (renamed from toolchain/gcc/patches/8.1.0/900-bad-mips16-crt.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/910-mbsd_multi.patch (renamed from toolchain/gcc/patches/8.1.0/910-mbsd_multi.patch)8
-rw-r--r--toolchain/gcc/patches/8.2.0/920-specs_nonfatal_getenv.patch (renamed from toolchain/gcc/patches/8.1.0/920-specs_nonfatal_getenv.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/930-fix-mips-noexecstack.patch (renamed from toolchain/gcc/patches/8.1.0/930-fix-mips-noexecstack.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/931-libffi-fix-MIPS-softfloat-build-issue.patch (renamed from toolchain/gcc/patches/8.1.0/931-libffi-fix-MIPS-softfloat-build-issue.patch)0
-rw-r--r--toolchain/gcc/patches/8.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch (renamed from toolchain/gcc/patches/8.1.0/960-gotools-fix-compilation-when-making-cross-compiler.patch)0
21 files changed, 8 insertions, 8 deletions
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index 6413e85219..55a942660e 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -19,5 +19,5 @@ config GCC_VERSION
string
default "5.5.0" if GCC_VERSION_5
default "arc-2017.09-release" if GCC_VERSION_7_1_ARC
- default "8.1.0" if GCC_VERSION_8
+ default "8.2.0" if GCC_VERSION_8
default "7.3.0"
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 1e17620156..b3e1d8edba 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -36,8 +36,8 @@ ifeq ($(PKG_VERSION),7.3.0)
PKG_HASH:=832ca6ae04636adbb430e865a1451adf6979ab44ca1c8374f61fba65645ce15c
endif
-ifeq ($(PKG_VERSION),8.1.0)
- PKG_HASH:=1d1866f992626e61349a1ccd0b8d5253816222cdc13390dcfaa74b093aa2b153
+ifeq ($(PKG_VERSION),8.2.0)
+ PKG_HASH:=196c3c04ba2613f893283977e6011b2345d1cd1af9abeac58e916b1aab3e0080
endif
ifneq ($(CONFIG_GCC_VERSION_7_1_ARC),)
diff --git a/toolchain/gcc/patches/8.1.0/002-case_insensitive.patch b/toolchain/gcc/patches/8.2.0/002-case_insensitive.patch
index 3442076d7d..3442076d7d 100644
--- a/toolchain/gcc/patches/8.1.0/002-case_insensitive.patch
+++ b/toolchain/gcc/patches/8.2.0/002-case_insensitive.patch
diff --git a/toolchain/gcc/patches/8.1.0/010-documentation.patch b/toolchain/gcc/patches/8.2.0/010-documentation.patch
index c3a6a15901..c3a6a15901 100644
--- a/toolchain/gcc/patches/8.1.0/010-documentation.patch
+++ b/toolchain/gcc/patches/8.2.0/010-documentation.patch
diff --git a/toolchain/gcc/patches/8.1.0/110-Fix-MIPS-PR-84790.patch b/toolchain/gcc/patches/8.2.0/110-Fix-MIPS-PR-84790.patch
index b89eca2faf..b89eca2faf 100644
--- a/toolchain/gcc/patches/8.1.0/110-Fix-MIPS-PR-84790.patch
+++ b/toolchain/gcc/patches/8.2.0/110-Fix-MIPS-PR-84790.patch
diff --git a/toolchain/gcc/patches/8.1.0/230-musl_libssp.patch b/toolchain/gcc/patches/8.2.0/230-musl_libssp.patch
index b3ab79cafb..b3ab79cafb 100644
--- a/toolchain/gcc/patches/8.1.0/230-musl_libssp.patch
+++ b/toolchain/gcc/patches/8.2.0/230-musl_libssp.patch
diff --git a/toolchain/gcc/patches/8.1.0/300-mips_Os_cpu_rtx_cost_model.patch b/toolchain/gcc/patches/8.2.0/300-mips_Os_cpu_rtx_cost_model.patch
index 6f97356ac6..6f97356ac6 100644
--- a/toolchain/gcc/patches/8.1.0/300-mips_Os_cpu_rtx_cost_model.patch
+++ b/toolchain/gcc/patches/8.2.0/300-mips_Os_cpu_rtx_cost_model.patch
diff --git a/toolchain/gcc/patches/8.1.0/800-arm_v5te_no_ldrd_strd.patch b/toolchain/gcc/patches/8.2.0/800-arm_v5te_no_ldrd_strd.patch
index 172295f28b..172295f28b 100644
--- a/toolchain/gcc/patches/8.1.0/800-arm_v5te_no_ldrd_strd.patch
+++ b/toolchain/gcc/patches/8.2.0/800-arm_v5te_no_ldrd_strd.patch
diff --git a/toolchain/gcc/patches/8.1.0/810-arm-softfloat-libgcc.patch b/toolchain/gcc/patches/8.2.0/810-arm-softfloat-libgcc.patch
index 5c9d86aead..5c9d86aead 100644
--- a/toolchain/gcc/patches/8.1.0/810-arm-softfloat-libgcc.patch
+++ b/toolchain/gcc/patches/8.2.0/810-arm-softfloat-libgcc.patch
diff --git a/toolchain/gcc/patches/8.1.0/820-libgcc_pic.patch b/toolchain/gcc/patches/8.2.0/820-libgcc_pic.patch
index 1a9678d480..1a9678d480 100644
--- a/toolchain/gcc/patches/8.1.0/820-libgcc_pic.patch
+++ b/toolchain/gcc/patches/8.2.0/820-libgcc_pic.patch
diff --git a/toolchain/gcc/patches/8.1.0/840-armv4_pass_fix-v4bx_to_ld.patch b/toolchain/gcc/patches/8.2.0/840-armv4_pass_fix-v4bx_to_ld.patch
index b9c9b161ad..b9c9b161ad 100644
--- a/toolchain/gcc/patches/8.1.0/840-armv4_pass_fix-v4bx_to_ld.patch
+++ b/toolchain/gcc/patches/8.2.0/840-armv4_pass_fix-v4bx_to_ld.patch
diff --git a/toolchain/gcc/patches/8.1.0/850-use_shared_libgcc.patch b/toolchain/gcc/patches/8.2.0/850-use_shared_libgcc.patch
index f619f0e6a1..f619f0e6a1 100644
--- a/toolchain/gcc/patches/8.1.0/850-use_shared_libgcc.patch
+++ b/toolchain/gcc/patches/8.2.0/850-use_shared_libgcc.patch
diff --git a/toolchain/gcc/patches/8.1.0/851-libgcc_no_compat.patch b/toolchain/gcc/patches/8.2.0/851-libgcc_no_compat.patch
index d710e40717..d710e40717 100644
--- a/toolchain/gcc/patches/8.1.0/851-libgcc_no_compat.patch
+++ b/toolchain/gcc/patches/8.2.0/851-libgcc_no_compat.patch
diff --git a/toolchain/gcc/patches/8.1.0/870-ppc_no_crtsavres.patch b/toolchain/gcc/patches/8.2.0/870-ppc_no_crtsavres.patch
index a73081493b..ecaf75a476 100644
--- a/toolchain/gcc/patches/8.1.0/870-ppc_no_crtsavres.patch
+++ b/toolchain/gcc/patches/8.2.0/870-ppc_no_crtsavres.patch
@@ -1,6 +1,6 @@
--- a/gcc/config/rs6000/rs6000.c
+++ b/gcc/config/rs6000/rs6000.c
-@@ -24424,7 +24424,7 @@ rs6000_savres_strategy (rs6000_stack_t *
+@@ -24501,7 +24501,7 @@ rs6000_savres_strategy (rs6000_stack_t *
/* Define cutoff for using out-of-line functions to save registers. */
if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
{
diff --git a/toolchain/gcc/patches/8.1.0/881-no_tm_section.patch b/toolchain/gcc/patches/8.2.0/881-no_tm_section.patch
index fab5db3be5..fab5db3be5 100644
--- a/toolchain/gcc/patches/8.1.0/881-no_tm_section.patch
+++ b/toolchain/gcc/patches/8.2.0/881-no_tm_section.patch
diff --git a/toolchain/gcc/patches/8.1.0/900-bad-mips16-crt.patch b/toolchain/gcc/patches/8.2.0/900-bad-mips16-crt.patch
index dd6e9dc889..dd6e9dc889 100644
--- a/toolchain/gcc/patches/8.1.0/900-bad-mips16-crt.patch
+++ b/toolchain/gcc/patches/8.2.0/900-bad-mips16-crt.patch
diff --git a/toolchain/gcc/patches/8.1.0/910-mbsd_multi.patch b/toolchain/gcc/patches/8.2.0/910-mbsd_multi.patch
index 83d41f2f1a..d9802b6d61 100644
--- a/toolchain/gcc/patches/8.1.0/910-mbsd_multi.patch
+++ b/toolchain/gcc/patches/8.2.0/910-mbsd_multi.patch
@@ -27,7 +27,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
static void handle_OPT_d (const char *);
static void set_std_cxx98 (int);
static void set_std_cxx11 (int);
-@@ -461,6 +464,12 @@ c_common_handle_option (size_t scode, co
+@@ -459,6 +462,12 @@ c_common_handle_option (size_t scode, co
flag_no_builtin = !value;
break;
@@ -40,7 +40,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
case OPT_fconstant_string_class_:
constant_string_class_name = arg;
break;
-@@ -1110,6 +1119,47 @@ c_common_init (void)
+@@ -1125,6 +1134,47 @@ c_common_init (void)
return false;
}
@@ -102,7 +102,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
Assume normal C execution environment.
--- a/gcc/common.opt
+++ b/gcc/common.opt
-@@ -1547,6 +1547,9 @@ fguess-branch-probability
+@@ -1551,6 +1551,9 @@ fguess-branch-probability
Common Report Var(flag_guess_branch_prob) Optimization
Enable guessing of branch probabilities.
@@ -126,7 +126,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
opts->x_warn_larger_than = value != -1;
--- a/gcc/doc/invoke.texi
+++ b/gcc/doc/invoke.texi
-@@ -7005,6 +7005,17 @@ This option is only supported for C and
+@@ -7012,6 +7012,17 @@ This option is only supported for C and
@option{-Wall} and by @option{-Wpedantic}, which can be disabled with
@option{-Wno-pointer-sign}.
diff --git a/toolchain/gcc/patches/8.1.0/920-specs_nonfatal_getenv.patch b/toolchain/gcc/patches/8.2.0/920-specs_nonfatal_getenv.patch
index c3836e63af..c3836e63af 100644
--- a/toolchain/gcc/patches/8.1.0/920-specs_nonfatal_getenv.patch
+++ b/toolchain/gcc/patches/8.2.0/920-specs_nonfatal_getenv.patch
diff --git a/toolchain/gcc/patches/8.1.0/930-fix-mips-noexecstack.patch b/toolchain/gcc/patches/8.2.0/930-fix-mips-noexecstack.patch
index 706d67f7c9..706d67f7c9 100644
--- a/toolchain/gcc/patches/8.1.0/930-fix-mips-noexecstack.patch
+++ b/toolchain/gcc/patches/8.2.0/930-fix-mips-noexecstack.patch
diff --git a/toolchain/gcc/patches/8.1.0/931-libffi-fix-MIPS-softfloat-build-issue.patch b/toolchain/gcc/patches/8.2.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
index fb4cb1533a..fb4cb1533a 100644
--- a/toolchain/gcc/patches/8.1.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
+++ b/toolchain/gcc/patches/8.2.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
diff --git a/toolchain/gcc/patches/8.1.0/960-gotools-fix-compilation-when-making-cross-compiler.patch b/toolchain/gcc/patches/8.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch
index 1dd05080d3..1dd05080d3 100644
--- a/toolchain/gcc/patches/8.1.0/960-gotools-fix-compilation-when-making-cross-compiler.patch
+++ b/toolchain/gcc/patches/8.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch