aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorSyrone Wong <wong.syrone@gmail.com>2018-07-26 22:38:57 +0800
committerFelix Fietkau <nbd@nbd.name>2018-08-20 09:24:29 +0200
commit713cee6463a8b654d2c72e469112130373c1336b (patch)
tree3ccf98b6c2c0e1e7ebcc3e943cb4b9f1aaf6bb23 /toolchain/gcc
parentfc9cbf3bc0673c97e31693ea45fad1798346c2cd (diff)
downloadupstream-713cee6463a8b654d2c72e469112130373c1336b.tar.gz
upstream-713cee6463a8b654d2c72e469112130373c1336b.tar.bz2
upstream-713cee6463a8b654d2c72e469112130373c1336b.zip
toolchain/gcc: add config symbol to determine how to apply path remapping
Added boolean symbol for GCC 8 and higher, when we add newer GCC, we don't have to modify rules.mk to keep things consistant. Fixes: da9d760 ("rules.mk: replace iremap when using GCC 8") Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.version5
1 files changed, 5 insertions, 0 deletions
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index 97c5e50dad..6413e85219 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -10,6 +10,11 @@ config GCC_VERSION_8
default y if GCC_USE_VERSION_8
bool
+config GCC_USE_EMBEDDED_PATH_REMAP
+ default y if GCC_VERSION_8
+ default n
+ bool
+
config GCC_VERSION
string
default "5.5.0" if GCC_VERSION_5