aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-01-27 14:28:46 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-01-27 19:54:52 +0100
commit1a8523c83530fcfc2607723e803e347dd5c50ec4 (patch)
tree2197bbab6c8be659021e16422389d2b315f494cd /toolchain/gcc
parent241e6dd3e92c4f215b8ac75379a4b5aeaeb92171 (diff)
downloadupstream-1a8523c83530fcfc2607723e803e347dd5c50ec4.tar.gz
upstream-1a8523c83530fcfc2607723e803e347dd5c50ec4.tar.bz2
upstream-1a8523c83530fcfc2607723e803e347dd5c50ec4.zip
toolchain: gcc: update 7.x to 7.3.0
This version still generates broken code in our setup for MIPS. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.version2
-rw-r--r--toolchain/gcc/common.mk4
-rw-r--r--toolchain/gcc/patches/7.3.0/001-revert_register_mode_search.patch (renamed from toolchain/gcc/patches/7.2.0/001-revert_register_mode_search.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/002-case_insensitive.patch (renamed from toolchain/gcc/patches/7.2.0/002-case_insensitive.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/010-documentation.patch (renamed from toolchain/gcc/patches/7.2.0/010-documentation.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/230-musl_libssp.patch (renamed from toolchain/gcc/patches/7.2.0/230-musl_libssp.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/300-mips_Os_cpu_rtx_cost_model.patch (renamed from toolchain/gcc/patches/7.2.0/300-mips_Os_cpu_rtx_cost_model.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/800-arm_v5te_no_ldrd_strd.patch (renamed from toolchain/gcc/patches/7.2.0/800-arm_v5te_no_ldrd_strd.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/810-arm-softfloat-libgcc.patch (renamed from toolchain/gcc/patches/7.2.0/810-arm-softfloat-libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/820-libgcc_pic.patch (renamed from toolchain/gcc/patches/7.2.0/820-libgcc_pic.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/840-armv4_pass_fix-v4bx_to_ld.patch (renamed from toolchain/gcc/patches/7.2.0/840-armv4_pass_fix-v4bx_to_ld.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/850-use_shared_libgcc.patch (renamed from toolchain/gcc/patches/7.2.0/850-use_shared_libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/851-libgcc_no_compat.patch (renamed from toolchain/gcc/patches/7.2.0/851-libgcc_no_compat.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/870-ppc_no_crtsavres.patch (renamed from toolchain/gcc/patches/7.2.0/870-ppc_no_crtsavres.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/881-no_tm_section.patch (renamed from toolchain/gcc/patches/7.2.0/881-no_tm_section.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/900-bad-mips16-crt.patch (renamed from toolchain/gcc/patches/7.2.0/900-bad-mips16-crt.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/910-mbsd_multi.patch (renamed from toolchain/gcc/patches/7.2.0/910-mbsd_multi.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/920-specs_nonfatal_getenv.patch (renamed from toolchain/gcc/patches/7.2.0/920-specs_nonfatal_getenv.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/930-fix-mips-noexecstack.patch (renamed from toolchain/gcc/patches/7.2.0/930-fix-mips-noexecstack.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/940-no-clobber-stamp-bits.patch (renamed from toolchain/gcc/patches/7.2.0/940-no-clobber-stamp-bits.patch)0
-rw-r--r--toolchain/gcc/patches/7.3.0/950-cpp_file_path_translation.patch (renamed from toolchain/gcc/patches/7.2.0/950-cpp_file_path_translation.patch)0
21 files changed, 3 insertions, 3 deletions
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index ee0f3f10c3..307a3657ac 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -6,7 +6,7 @@ config GCC_VERSION
string
default "arc-2017.09-release" if GCC_VERSION_7_1_ARC
default "6.3.0" if GCC_USE_VERSION_6
- default "7.2.0" if GCC_USE_VERSION_7
+ default "7.3.0" if GCC_USE_VERSION_7
default "5.5.0"
config GCC_VERSION_7_1
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index fafc0c1671..fb60e57c73 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -37,8 +37,8 @@ ifeq ($(PKG_VERSION),6.3.0)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
endif
-ifeq ($(PKG_VERSION),7.2.0)
- PKG_HASH:=1cf7adf8ff4b5aa49041c8734bbcf1ad18cc4c94d0029aae0f4e48841088479a
+ifeq ($(PKG_VERSION),7.3.0)
+ PKG_HASH:=832ca6ae04636adbb430e865a1451adf6979ab44ca1c8374f61fba65645ce15c
endif
ifneq ($(CONFIG_GCC_VERSION_7_1_ARC),)
diff --git a/toolchain/gcc/patches/7.2.0/001-revert_register_mode_search.patch b/toolchain/gcc/patches/7.3.0/001-revert_register_mode_search.patch
index 63e3fee003..63e3fee003 100644
--- a/toolchain/gcc/patches/7.2.0/001-revert_register_mode_search.patch
+++ b/toolchain/gcc/patches/7.3.0/001-revert_register_mode_search.patch
diff --git a/toolchain/gcc/patches/7.2.0/002-case_insensitive.patch b/toolchain/gcc/patches/7.3.0/002-case_insensitive.patch
index 3442076d7d..3442076d7d 100644
--- a/toolchain/gcc/patches/7.2.0/002-case_insensitive.patch
+++ b/toolchain/gcc/patches/7.3.0/002-case_insensitive.patch
diff --git a/toolchain/gcc/patches/7.2.0/010-documentation.patch b/toolchain/gcc/patches/7.3.0/010-documentation.patch
index 0106814f41..0106814f41 100644
--- a/toolchain/gcc/patches/7.2.0/010-documentation.patch
+++ b/toolchain/gcc/patches/7.3.0/010-documentation.patch
diff --git a/toolchain/gcc/patches/7.2.0/230-musl_libssp.patch b/toolchain/gcc/patches/7.3.0/230-musl_libssp.patch
index eebee9175c..eebee9175c 100644
--- a/toolchain/gcc/patches/7.2.0/230-musl_libssp.patch
+++ b/toolchain/gcc/patches/7.3.0/230-musl_libssp.patch
diff --git a/toolchain/gcc/patches/7.2.0/300-mips_Os_cpu_rtx_cost_model.patch b/toolchain/gcc/patches/7.3.0/300-mips_Os_cpu_rtx_cost_model.patch
index 84c0fdab66..84c0fdab66 100644
--- a/toolchain/gcc/patches/7.2.0/300-mips_Os_cpu_rtx_cost_model.patch
+++ b/toolchain/gcc/patches/7.3.0/300-mips_Os_cpu_rtx_cost_model.patch
diff --git a/toolchain/gcc/patches/7.2.0/800-arm_v5te_no_ldrd_strd.patch b/toolchain/gcc/patches/7.3.0/800-arm_v5te_no_ldrd_strd.patch
index 76200a1661..76200a1661 100644
--- a/toolchain/gcc/patches/7.2.0/800-arm_v5te_no_ldrd_strd.patch
+++ b/toolchain/gcc/patches/7.3.0/800-arm_v5te_no_ldrd_strd.patch
diff --git a/toolchain/gcc/patches/7.2.0/810-arm-softfloat-libgcc.patch b/toolchain/gcc/patches/7.3.0/810-arm-softfloat-libgcc.patch
index 5c9d86aead..5c9d86aead 100644
--- a/toolchain/gcc/patches/7.2.0/810-arm-softfloat-libgcc.patch
+++ b/toolchain/gcc/patches/7.3.0/810-arm-softfloat-libgcc.patch
diff --git a/toolchain/gcc/patches/7.2.0/820-libgcc_pic.patch b/toolchain/gcc/patches/7.3.0/820-libgcc_pic.patch
index 0cc1e07e2b..0cc1e07e2b 100644
--- a/toolchain/gcc/patches/7.2.0/820-libgcc_pic.patch
+++ b/toolchain/gcc/patches/7.3.0/820-libgcc_pic.patch
diff --git a/toolchain/gcc/patches/7.2.0/840-armv4_pass_fix-v4bx_to_ld.patch b/toolchain/gcc/patches/7.3.0/840-armv4_pass_fix-v4bx_to_ld.patch
index b9c9b161ad..b9c9b161ad 100644
--- a/toolchain/gcc/patches/7.2.0/840-armv4_pass_fix-v4bx_to_ld.patch
+++ b/toolchain/gcc/patches/7.3.0/840-armv4_pass_fix-v4bx_to_ld.patch
diff --git a/toolchain/gcc/patches/7.2.0/850-use_shared_libgcc.patch b/toolchain/gcc/patches/7.3.0/850-use_shared_libgcc.patch
index 1d07efed80..1d07efed80 100644
--- a/toolchain/gcc/patches/7.2.0/850-use_shared_libgcc.patch
+++ b/toolchain/gcc/patches/7.3.0/850-use_shared_libgcc.patch
diff --git a/toolchain/gcc/patches/7.2.0/851-libgcc_no_compat.patch b/toolchain/gcc/patches/7.3.0/851-libgcc_no_compat.patch
index d710e40717..d710e40717 100644
--- a/toolchain/gcc/patches/7.2.0/851-libgcc_no_compat.patch
+++ b/toolchain/gcc/patches/7.3.0/851-libgcc_no_compat.patch
diff --git a/toolchain/gcc/patches/7.2.0/870-ppc_no_crtsavres.patch b/toolchain/gcc/patches/7.3.0/870-ppc_no_crtsavres.patch
index 156468b45e..156468b45e 100644
--- a/toolchain/gcc/patches/7.2.0/870-ppc_no_crtsavres.patch
+++ b/toolchain/gcc/patches/7.3.0/870-ppc_no_crtsavres.patch
diff --git a/toolchain/gcc/patches/7.2.0/881-no_tm_section.patch b/toolchain/gcc/patches/7.3.0/881-no_tm_section.patch
index a58dc27e64..a58dc27e64 100644
--- a/toolchain/gcc/patches/7.2.0/881-no_tm_section.patch
+++ b/toolchain/gcc/patches/7.3.0/881-no_tm_section.patch
diff --git a/toolchain/gcc/patches/7.2.0/900-bad-mips16-crt.patch b/toolchain/gcc/patches/7.3.0/900-bad-mips16-crt.patch
index f5cc0a74ee..f5cc0a74ee 100644
--- a/toolchain/gcc/patches/7.2.0/900-bad-mips16-crt.patch
+++ b/toolchain/gcc/patches/7.3.0/900-bad-mips16-crt.patch
diff --git a/toolchain/gcc/patches/7.2.0/910-mbsd_multi.patch b/toolchain/gcc/patches/7.3.0/910-mbsd_multi.patch
index 286cfadae7..286cfadae7 100644
--- a/toolchain/gcc/patches/7.2.0/910-mbsd_multi.patch
+++ b/toolchain/gcc/patches/7.3.0/910-mbsd_multi.patch
diff --git a/toolchain/gcc/patches/7.2.0/920-specs_nonfatal_getenv.patch b/toolchain/gcc/patches/7.3.0/920-specs_nonfatal_getenv.patch
index 69b40621dc..69b40621dc 100644
--- a/toolchain/gcc/patches/7.2.0/920-specs_nonfatal_getenv.patch
+++ b/toolchain/gcc/patches/7.3.0/920-specs_nonfatal_getenv.patch
diff --git a/toolchain/gcc/patches/7.2.0/930-fix-mips-noexecstack.patch b/toolchain/gcc/patches/7.3.0/930-fix-mips-noexecstack.patch
index 90d10f11e4..90d10f11e4 100644
--- a/toolchain/gcc/patches/7.2.0/930-fix-mips-noexecstack.patch
+++ b/toolchain/gcc/patches/7.3.0/930-fix-mips-noexecstack.patch
diff --git a/toolchain/gcc/patches/7.2.0/940-no-clobber-stamp-bits.patch b/toolchain/gcc/patches/7.3.0/940-no-clobber-stamp-bits.patch
index 8b88b4066d..8b88b4066d 100644
--- a/toolchain/gcc/patches/7.2.0/940-no-clobber-stamp-bits.patch
+++ b/toolchain/gcc/patches/7.3.0/940-no-clobber-stamp-bits.patch
diff --git a/toolchain/gcc/patches/7.2.0/950-cpp_file_path_translation.patch b/toolchain/gcc/patches/7.3.0/950-cpp_file_path_translation.patch
index 60729dd7fe..60729dd7fe 100644
--- a/toolchain/gcc/patches/7.2.0/950-cpp_file_path_translation.patch
+++ b/toolchain/gcc/patches/7.3.0/950-cpp_file_path_translation.patch