aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorJulien Dusser <julien.dusser@free.fr>2018-01-07 18:47:21 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-01-27 19:02:48 +0100
commit241e6dd3e92c4f215b8ac75379a4b5aeaeb92171 (patch)
treedf5884c1112280f9d9c04f292e854e55e7b29bb1 /toolchain/gcc
parent55779569eb817361222d653accd929a752b8327d (diff)
downloadupstream-241e6dd3e92c4f215b8ac75379a4b5aeaeb92171.tar.gz
upstream-241e6dd3e92c4f215b8ac75379a4b5aeaeb92171.tar.bz2
upstream-241e6dd3e92c4f215b8ac75379a4b5aeaeb92171.zip
build: cleanup SSP_SUPPORT configure option
Configure variable SSP_SUPPORT is ambiguous for packages (tor, openssh, avahi, freeswitch). It means 'toolchain supporting SSP', but for toolchain and depends it means 'build gcc with libssp'. Musl no longer uses libssp (1877bc9d8f), it has internal support, so SSP_SUPPORT was disabled leading some package to not use SSP. No information why Glibc and uClibc use libssp, but they may also provide their own SSP support. uClibc used it own with commit 933b588e25 but it was reverted in f3cacb9e84 without details. Create an new configure GCC_LIBSSP and automatically enable SSP_SUPPORT if either USE_MUSL or GCC_LIBSSP. Signed-off-by: Julien Dusser <julien.dusser@free.fr>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.in4
-rw-r--r--toolchain/gcc/common.mk2
2 files changed, 3 insertions, 3 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 0fe0ea2957..30ac137873 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -52,9 +52,9 @@ config GCC_DEFAULT_SSP
help
Use gcc configure option --enable-default-ssp to turn on -fstack-protector-strong by default.
-config SSP_SUPPORT
+config GCC_LIBSSP
bool
- prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
+ prompt "Build gcc libssp" if TOOLCHAINOPTS
depends on !USE_MUSL
default y if !USE_MUSL
help
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index ece71ef028..fafc0c1671 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -143,7 +143,7 @@ ifneq ($(CONFIG_GCC_DEFAULT_SSP),)
--enable-default-ssp
endif
-ifneq ($(CONFIG_SSP_SUPPORT),)
+ifneq ($(CONFIG_GCC_LIBSSP),)
GCC_CONFIGURE+= \
--enable-libssp
else