aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/fortify-headers/Makefile
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-06-23 14:38:03 +0000
committerSteven Barth <cyrus@openwrt.org>2015-06-23 14:38:03 +0000
commit2738526a16f9ebd100ac7a35d55b13e91e45e888 (patch)
treee63e9fe54643978c4bd5a3030e6d4fd59948099f /toolchain/fortify-headers/Makefile
parent2086f7284c63d759071729108e35687c4679b9fc (diff)
downloadupstream-2738526a16f9ebd100ac7a35d55b13e91e45e888.tar.gz
upstream-2738526a16f9ebd100ac7a35d55b13e91e45e888.tar.bz2
upstream-2738526a16f9ebd100ac7a35d55b13e91e45e888.zip
toolchain: add fortify-headers, enable FORTIFY_SOURCE by default
Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 46117
Diffstat (limited to 'toolchain/fortify-headers/Makefile')
-rw-r--r--toolchain/fortify-headers/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/toolchain/fortify-headers/Makefile b/toolchain/fortify-headers/Makefile
new file mode 100644
index 0000000000..b9cefe5935
--- /dev/null
+++ b/toolchain/fortify-headers/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
+
+PKG_NAME:=fortify-headers
+PKG_VERSION:=0.6
+PKG_RELEASE=1
+
+PKG_SOURCE_URL:=http://dl.2f30.org/releases
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=d85072939ec02a40af282fe3febc6c18
+
+include $(INCLUDE_DIR)/toolchain-build.mk
+
+define Host/Compile
+ true
+endef
+
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) PREFIX="" DESTDIR="$(TOOLCHAIN_DIR)" install
+endef
+
+$(eval $(call HostBuild))