aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/fortify-headers
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-06-23 14:38:03 +0000
committerSteven Barth <cyrus@openwrt.org>2015-06-23 14:38:03 +0000
commit2738526a16f9ebd100ac7a35d55b13e91e45e888 (patch)
treee63e9fe54643978c4bd5a3030e6d4fd59948099f /toolchain/fortify-headers
parent2086f7284c63d759071729108e35687c4679b9fc (diff)
downloadupstream-2738526a16f9ebd100ac7a35d55b13e91e45e888.tar.gz
upstream-2738526a16f9ebd100ac7a35d55b13e91e45e888.tar.bz2
upstream-2738526a16f9ebd100ac7a35d55b13e91e45e888.zip
toolchain: add fortify-headers, enable FORTIFY_SOURCE by default
Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 46117
Diffstat (limited to 'toolchain/fortify-headers')
-rw-r--r--toolchain/fortify-headers/Makefile28
-rw-r--r--toolchain/fortify-headers/patches/100-fix-getgroups.patch26
2 files changed, 54 insertions, 0 deletions
diff --git a/toolchain/fortify-headers/Makefile b/toolchain/fortify-headers/Makefile
new file mode 100644
index 0000000000..b9cefe5935
--- /dev/null
+++ b/toolchain/fortify-headers/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
+
+PKG_NAME:=fortify-headers
+PKG_VERSION:=0.6
+PKG_RELEASE=1
+
+PKG_SOURCE_URL:=http://dl.2f30.org/releases
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=d85072939ec02a40af282fe3febc6c18
+
+include $(INCLUDE_DIR)/toolchain-build.mk
+
+define Host/Compile
+ true
+endef
+
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) PREFIX="" DESTDIR="$(TOOLCHAIN_DIR)" install
+endef
+
+$(eval $(call HostBuild))
diff --git a/toolchain/fortify-headers/patches/100-fix-getgroups.patch b/toolchain/fortify-headers/patches/100-fix-getgroups.patch
new file mode 100644
index 0000000000..988deb5815
--- /dev/null
+++ b/toolchain/fortify-headers/patches/100-fix-getgroups.patch
@@ -0,0 +1,26 @@
+From 1f9848efc8a329cb9a13323cbb94b353d39802c1 Mon Sep 17 00:00:00 2001
+From: Steven Barth <steven@midlink.org>
+Date: Mon, 22 Jun 2015 14:36:16 +0200
+Subject: [PATCH] unistd: fix signed / unsigned comparison in getgroups
+
+Signed-off-by: Steven Barth <steven@midlink.org>
+---
+ include/unistd.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/unistd.h b/include/unistd.h
+index 45304e1..5274e22 100644
+--- a/include/unistd.h
++++ b/include/unistd.h
+@@ -71,7 +71,7 @@ _FORTIFY_FN(getgroups) int getgroups(int __l, gid_t *__s)
+ {
+ size_t __b = __builtin_object_size(__s, 0);
+
+- if (__l > __b / sizeof(gid_t))
++ if (__l < 0 || (size_t)__l > __b / sizeof(gid_t))
+ __builtin_trap();
+ return __orig_getgroups(__l, __s);
+ }
+--
+2.1.4
+