aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-11-25 13:25:29 +0100
committerMathias Kresin <dev@kresin.me>2016-12-24 10:03:38 +0100
commitd2b1148e755254e2e41417fd18de03882e13bba8 (patch)
tree659e1b5f1a5d0781b14da981bbd9b4468fbe26ea /target
parentd2b6bf141662429d542b23e9e8f44245a77710a5 (diff)
downloadupstream-d2b1148e755254e2e41417fd18de03882e13bba8.tar.gz
upstream-d2b1148e755254e2e41417fd18de03882e13bba8.tar.bz2
upstream-d2b1148e755254e2e41417fd18de03882e13bba8.zip
ramips: use D-Link DIR-600 B1 image for B2 version
Everything set for the B1 is identical to the values uses for the B2 version. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds1
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/DIR-600-B2.dts107
-rw-r--r--target/linux/ramips/image/rt305x-legacy.mk9
6 files changed, 1 insertions, 121 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index b7f3b36d8a..e6664bdd98 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -122,7 +122,6 @@ dcs-930l-b1)
;;
dir-300-b1|\
dir-600-b1|\
-dir-600-b2|\
dir-620-a1)
ucidef_set_led_default "wan" "WAN LED (amber)" "$board:amber:wan" "1"
set_wifi_led "rt2800pci-phy0::radio"
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index c4b753808f..6b64d3b385 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -63,7 +63,6 @@ get_status_led() {
dir-300-b7|\
dir-320-b1|\
dir-600-b1|\
- dir-600-b2|\
dir-610-a1|\
dir-615-d|\
dir-615-h1|\
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 695f20697d..bfb186ddf8 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -133,9 +133,6 @@ ramips_board_detect() {
*"DIR-600 B1")
name="dir-600-b1"
;;
- *"DIR-600 B2")
- name="dir-600-b2"
- ;;
*"DIR-610 A1")
name="dir-610-a1"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 78e87a09f2..c097cfa218 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -43,7 +43,6 @@ platform_check_image() {
dir-300-b7|\
dir-320-b1|\
dir-600-b1|\
- dir-600-b2|\
dir-615-d|\
dir-615-h1|\
dir-620-a1|\
diff --git a/target/linux/ramips/dts/DIR-600-B2.dts b/target/linux/ramips/dts/DIR-600-B2.dts
deleted file mode 100644
index f1f10ad254..0000000000
--- a/target/linux/ramips/dts/DIR-600-B2.dts
+++ /dev/null
@@ -1,107 +0,0 @@
-/dts-v1/;
-
-#include "rt3050.dtsi"
-
-#include <dt-bindings/input/input.h>
-
-/ {
- compatible = "DIR-600-B2", "ralink,rt3050-soc";
- model = "D-Link DIR-600 B2";
-
- cfi@1f000000 {
- compatible = "cfi-flash";
- reg = <0x1f000000 0x800000>;
- bank-width = <2>;
- device-width = <2>;
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x0 0x30000>;
- read-only;
- };
-
- devdata: partition@30000 {
- label = "devdata";
- reg = <0x30000 0x10000>;
- read-only;
- };
-
- partition@40000 {
- label = "devconf";
- reg = <0x40000 0x10000>;
- read-only;
- };
-
- partition@50000 {
- label = "firmware";
- reg = <0x50000 0x3b0000>;
- };
- };
-
- gpio-keys-polled {
- compatible = "gpio-keys-polled";
- #address-cells = <1>;
- #size-cells = <0>;
- poll-interval = <20>;
-
- reset {
- label = "reset";
- gpios = <&gpio0 10 1>;
- linux,code = <KEY_RESTART>;
- };
-
- wps {
- label = "wps";
- gpios = <&gpio0 0 1>;
- linux,code = <KEY_WPS_BUTTON>;
- };
- };
-
- gpio-leds {
- compatible = "gpio-leds";
-
- status {
- label = "dir-600-b2:amber:status";
- gpios = <&gpio0 8 1>;
- };
-
- status2 {
- label = "dir-600-b2:green:status";
- gpios = <&gpio0 9 1>;
- };
-
- wan {
- label = "dir-600-b2:amber:wan";
- gpios = <&gpio0 14 1>;
- };
-
- wan2 {
- label = "dir-600-b2:green:wan";
- gpios = <&gpio0 12 1>;
- };
-
- wps {
- label = "dir-600-b2:blue:wps";
- gpios = <&gpio0 13 1>;
- };
- };
-};
-
-&pinctrl {
- state_default: pinctrl0 {
- gpio {
- ralink,group = "i2c", "spi", "jtag", "mdio", "rgmii", "uartf";
- ralink,function = "gpio";
- };
- };
-};
-
-&esw {
- mediatek,portmap = <0x2f>;
-};
-
-&wmac {
- ralink,mtd-eeprom = <&devdata 0x4000>;
-};
diff --git a/target/linux/ramips/image/rt305x-legacy.mk b/target/linux/ramips/image/rt305x-legacy.mk
index 48ed73b05d..e3b26ed7af 100644
--- a/target/linux/ramips/image/rt305x-legacy.mk
+++ b/target/linux/ramips/image/rt305x-legacy.mk
@@ -157,7 +157,6 @@ Image/Build/Profile/JHR-N825R=$(call BuildFirmware/JCG/$(1),$(1),jhr-n825r,JHR-N
Image/Build/Profile/JHR-N926R=$(call BuildFirmware/JCG/$(1),$(1),jhr-n926r,JHR-N926R,25.24)
Image/Build/Profile/DIR-300-B1=$(call BuildFirmware/DIR300B1/$(1),$(1),dir-300-b1,DIR-300-B1,wrgn23_dlwbr_dir300b)
Image/Build/Profile/DIR-600-B1=$(call BuildFirmware/DIR300B1/$(1),$(1),dir-600-b1,DIR-600-B1,wrgn23_dlwbr_dir600b)
-Image/Build/Profile/DIR-600-B2=$(call BuildFirmware/DIR300B1/$(1),$(1),dir-600-b2,DIR-600-B2,wrgn23_dlwbr_dir600b)
Image/Build/Profile/DIR-615-D=$(call BuildFirmware/DIR300B1/$(1),$(1),dir-615-d,DIR-615-D,wrgn23_dlwbr_dir615d)
Image/Build/Profile/DAP1350=$(call BuildFirmware/dap1350/$(1),$(1),dap-1350,DAP-1350,RT3052-AP-DAP1350-3)
Image/Build/Profile/DAP1350WW=$(call BuildFirmware/dap1350/$(1),$(1),dap-1350WW,DAP-1350,RT3052-AP-DAP1350WW-3)
@@ -289,17 +288,11 @@ LEGACY_DEVICES += DIR-300-B1
define LegacyDevice/DIR-600-B1
- DEVICE_TITLE := D-Link DIR-600 B1
+ DEVICE_TITLE := D-Link DIR-600 B1/B2
endef
LEGACY_DEVICES += DIR-600-B1
-define LegacyDevice/DIR-600-B2
- DEVICE_TITLE := D-Link DIR-600 B2
-endef
-LEGACY_DEVICES += DIR-600-B2
-
-
define LegacyDevice/DIR-615-D
DEVICE_TITLE := D-Link DIR-615 D
endef