aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-12-01 07:37:03 +0100
committerMathias Kresin <dev@kresin.me>2016-12-24 10:03:38 +0100
commitd2b6bf141662429d542b23e9e8f44245a77710a5 (patch)
treece3935a111b0f358e3a6814ed88aeaa460141a59 /target
parentae3ac76e565724e188138dafe38ebeed122e2cf8 (diff)
downloadupstream-d2b6bf141662429d542b23e9e8f44245a77710a5.tar.gz
upstream-d2b6bf141662429d542b23e9e8f44245a77710a5.tar.bz2
upstream-d2b6bf141662429d542b23e9e8f44245a77710a5.zip
ramips: fix image validation errors
The name from the Device define will be used in the metadata. Due to typos/different spelling, this name might not match the one exported in /lib/ramips.sh. Fix all name mismatches which were found by checking if the name used in the metadata exists in /lib/ramips.sh. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh2
-rw-r--r--target/linux/ramips/image/mt7620.mk2
-rw-r--r--target/linux/ramips/image/rt288x.mk4
-rw-r--r--target/linux/ramips/image/rt305x.mk20
4 files changed, 15 insertions, 13 deletions
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 31a2049696..695f20697d 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -260,7 +260,7 @@ ramips_board_detect() {
name="m2m"
;;
*"Mercury MAC1200R v2")
- name="mac1200rv2"
+ name="mac1200r-v2"
;;
*"MicroWRT")
name="microwrt"
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 24b78cb97b..a8c7f5c8c7 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -43,6 +43,7 @@ endef
define Device/ArcherC20i
DTS := ArcherC20i
+ SUPPORTED_DEVICES := c20i
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC20i -c
IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC20i -j | append-metadata
@@ -52,6 +53,7 @@ TARGET_DEVICES += ArcherC20i
define Device/ArcherC50
DTS := ArcherC50
+ SUPPORTED_DEVICES := c50
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC50 -c
IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC50 -j | append-metadata
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index f9584a34ab..3312d0ed17 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -27,14 +27,14 @@ define Device/ar725w
endef
TARGET_DEVICES += ar725w
-define Device/f5d8235v1
+define Device/f5d8235-v1
DTS := F5D8235_V1
IMAGE_SIZE := 7744k
DEVICE_TITLE := Belkin F5D8235 V1
DEVICE_PACKAGES := kmod-switch-rtl8366s kmod-usb-core kmod-usb-ohci \
kmod-usb-ohci-pci kmod-usb2 kmod-usb2-pci kmod-usb-ledtrig-usbport
endef
-TARGET_DEVICES += f5d8235v1
+TARGET_DEVICES += f5d8235-v1
define Device/rt-n15
DTS := RT-N15
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index fed600d1e1..c7e18cb748 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -94,12 +94,12 @@ endef
TARGET_DEVICES += atp-52b
-define Device/f5d8235v2
+define Device/f5d8235-v2
DTS := F5D8235_V2
IMAGE_SIZE := 7744k
DEVICE_TITLE := Belkin F5D8235 v2
endef
-TARGET_DEVICES += f5d8235v2
+TARGET_DEVICES += f5d8235-v2
define Device/f7c027
@@ -127,13 +127,13 @@ endef
TARGET_DEVICES += awm003-evb
-define Device/awmapn2403
+define Device/awapn2403
DTS := AWAPN2403
BLOCKSIZE := 4k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_TITLE := AsiaRF AWAPN2403
endef
-TARGET_DEVICES += awmapn2403
+TARGET_DEVICES += awapn2403
define Device/bc2
@@ -316,13 +316,13 @@ endef
TARGET_DEVICES += mzk-wdpr
-define Device/ncs601W
+define Device/ncs601w
DTS := NCS601W
DEVICE_TITLE := Wansview NCS601W
DEVICE_PACKAGES := kmod-video-core kmod-video-uvc \
kmod-usb-core kmod-usb-ohci
endef
-TARGET_DEVICES += ncs601W
+TARGET_DEVICES += ncs601w
define Device/m2m
@@ -444,13 +444,13 @@ endef
TARGET_DEVICES += w502u
-define Device/wcr150gn
+define Device/wcr-150gn
DTS := WCR150GN
BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_TITLE := Sparklan WCR-150GN
endef
-TARGET_DEVICES += wcr150gn
+TARGET_DEVICES += wcr-150gn
define Device/mzk-dp150n
@@ -463,12 +463,12 @@ endef
TARGET_DEVICES += mzk-dp150n
-define Device/wizard-8800
+define Device/wizard8800
DTS := WIZARD8800
UIMAGE_NAME:= Linux Kernel Image
DEVICE_TITLE := EasyAcc WIZARD 8800
endef
-TARGET_DEVICES += wizard-8800
+TARGET_DEVICES += wizard8800
define Device/wizfi630a