aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-12-23 14:27:16 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-12-23 14:27:16 +0000
commit7b1e525b56743a96c52cb25a6a12cbe7f5d58995 (patch)
tree1b0ad8600955e01020d2e0f3351f7685552fd30a /target
parent2cb946f5b4ebb720739b4dbb80c7821843f22ee5 (diff)
downloadupstream-7b1e525b56743a96c52cb25a6a12cbe7f5d58995.tar.gz
upstream-7b1e525b56743a96c52cb25a6a12cbe7f5d58995.tar.bz2
upstream-7b1e525b56743a96c52cb25a6a12cbe7f5d58995.zip
ramips: initial support for Sitecom WL-351 v1 002
This add support for the Sitecom WL-351 v1 002. In principle the Engenius ESR9850 should also work with this, but I don't have the hardware to test it. Since an external gigabit switch (RTL8366RB) is used, I had to modify the ramips_esw driver to add a 'bypass' mode, which just configures it to not filter the vlan tags. Also two initialization words (FCT2 and FPA2) are set to different values by u-boot than what the driver is using and it only seems to work correctly when they not overridden by the driver, so I added them to the platform specific data as reg_initval_fct2 and reg_initval_fpa2. With this wired lan works as expected, however I'm still having some trouble with the wireless lan: It only works after I rmmod & re-insmod rt2800pci and then reconfigure it in the webinterface, but not directly after rebooting. The symptom of this is wpad saying: Dec 20 15:45:09 OpenWrt daemon.info hostapd: wlan1: STA <notebookmac> IEEE 802.11: associated (aid 1) Dec 20 15:45:09 OpenWrt daemon.info hostapd: wlan1: STA <notebookmac> WPA: pairwise key handshake completed (RSN) Dec 20 15:45:22 OpenWrt daemon.info hostapd: wlan1: STA <notebookmac> IEEE 802.11: authenticated But wpa_supplicant on the client saying: Authentication with <wl351mac> timed out. Signed-off-by: Tobias Diedrich <ranma+openwrt@tdiedrich.de> SVN-Revision: 29604
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/diag.sh3
-rw-r--r--target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom1
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/network10
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rw-r--r--target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h1
-rw-r--r--target/linux/ramips/files/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h3
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig5
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile2
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/devices.c8
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/mach-wl351.c156
-rw-r--r--target/linux/ramips/files/drivers/net/ramips_esw.c16
-rw-r--r--target/linux/ramips/image/Makefile5
-rw-r--r--target/linux/ramips/rt305x/config-2.6.391
13 files changed, 209 insertions, 5 deletions
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index a150cc26d8..edb8376cdd 100755
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -66,6 +66,9 @@ get_status_led() {
whr-g300n)
status_led="whr-g300n:green:router"
;;
+ wl-351)
+ status_led="wl-351:amber:power"
+ ;;
esac
}
diff --git a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
index fa6607fd7f..a1d4887ecb 100644
--- a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
+++ b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
@@ -59,6 +59,7 @@ case "$FIRMWARE" in
v22rw-2x2 | \
wcr-150gn | \
whr-g300n | \
+ wl-351 | \
wr512-3gn)
rt2x00_eeprom_extract "factory" 0 272
;;
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/network b/target/linux/ramips/base-files/etc/uci-defaults/network
index bb1d90ef48..60dd716080 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/network
+++ b/target/linux/ramips/base-files/etc/uci-defaults/network
@@ -23,6 +23,13 @@ ramips_setup_interfaces()
ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
;;
+ wl-351)
+ ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
+ ucidef_add_switch "rtl8366rb" "1" "1"
+ ucidef_add_switch_vlan "rtl8366rb" "1" "0 1 2 3 5t"
+ ucidef_add_switch_vlan "rtl8366rb" "2" "4 5t"
+ ;;
+
rt-n15)
ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
ucidef_add_switch "rtl8366s" "1" "1"
@@ -56,7 +63,8 @@ ramips_setup_macs()
argus-atp52b | \
b2c | \
nw718 | \
- rt-n15)
+ rt-n15 | \
+ wl-351)
lan_mac=$(ramips_get_mac_binary factory 4)
wan_mac=$(/usr/sbin/maccalc add "$lan_mac" 1)
;;
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index faed42162c..4dc10aeb22 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -104,6 +104,9 @@ ramips_board_name() {
*"WHR-G300N")
name="whr-g300n"
;;
+ *"Sitecom WL-351 v1 002")
+ name="wl-351"
+ ;;
*"WZR-AGL300NH")
name="wzr-agl300nh"
;;
diff --git a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
index 4076d6c500..712976082b 100644
--- a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
+++ b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
@@ -38,5 +38,6 @@ enum ramips_mach_type {
RAMIPS_MACH_V22RW_2X2, /* Ralink AP-RT3052-V22RW-2X2 */
RAMIPS_MACH_WCR150GN, /* Sparklan WCR-150GN */
RAMIPS_MACH_WHR_G300N, /* Buffalo WHR-G300N */
+ RAMIPS_MACH_WL351, /* Sitecom WL-351 v1 002 */
RAMIPS_MACH_WR512_3GN, /* SH-WR512NU/WS-WR512N1-like 3GN*/
};
diff --git a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h
index 97ee375eb7..9634322d14 100644
--- a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h
+++ b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h
@@ -13,6 +13,7 @@
enum {
RT305X_ESW_VLAN_CONFIG_NONE = 0,
+ RT305X_ESW_VLAN_CONFIG_BYPASS,
RT305X_ESW_VLAN_CONFIG_LLLLW,
RT305X_ESW_VLAN_CONFIG_WLLLL,
};
@@ -20,6 +21,8 @@ enum {
struct rt305x_esw_platform_data
{
u8 vlan_config;
+ u32 reg_initval_fct2;
+ u32 reg_initval_fpa2;
};
#endif /* _RT305X_ESW_PLATFORM_H */
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
index 3e58242161..3149af4c88 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
@@ -76,6 +76,11 @@ config RT305X_MACH_V22RW_2X2
select RALINK_DEV_GPIO_BUTTONS
select RALINK_DEV_GPIO_LEDS
+config RT305X_MACH_WL351
+ bool "Sitecom WL-351 support"
+ select RALINK_DEV_GPIO_BUTTONS
+ select RALINK_DEV_GPIO_LEDS
+
config RT305X_MACH_WCR150GN
bool "Sparklan WCR-150GN support"
select RALINK_DEV_GPIO_BUTTONS
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
index 5da73155f9..2778f54f05 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
@@ -28,4 +28,4 @@ obj-$(CONFIG_RT305X_MACH_V22RW_2X2) += mach-v22rw-2x2.o
obj-$(CONFIG_RT305X_MACH_WCR150GN) += mach-wcr150gn.o
obj-$(CONFIG_RT305X_MACH_WHR_G300N) += mach-whr-g300n.o
obj-$(CONFIG_RT305X_MACH_WR512_3GN) += mach-wr512-3gn.o
-
+obj-$(CONFIG_RT305X_MACH_WL351) += mach-wl351.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/devices.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/devices.c
index 5dfbddbf2b..615f32dacc 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/devices.c
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/devices.c
@@ -24,6 +24,7 @@
#include "devices.h"
#include <ramips_eth_platform.h>
+#include <rt305x_esw_platform.h>
static struct resource rt305x_flash0_resources[] = {
{
@@ -142,7 +143,12 @@ static struct resource rt305x_esw_resources[] = {
},
};
-struct rt305x_esw_platform_data rt305x_esw_data;
+struct rt305x_esw_platform_data rt305x_esw_data = {
+ .vlan_config = RT305X_ESW_VLAN_CONFIG_NONE,
+ .reg_initval_fct2 = 0x00d6500c,
+ .reg_initval_fpa2 = 0x3f502b28,
+};
+
static struct platform_device rt305x_esw_device = {
.name = "rt305x-esw",
.resource = rt305x_esw_resources,
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-wl351.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-wl351.c
new file mode 100644
index 0000000000..3ebc7fee8b
--- /dev/null
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-wl351.c
@@ -0,0 +1,156 @@
+/*
+ * Sitecom WL-351 v1 002 board support
+ *
+ * Copyright (C) 2011 Tobias Diedrich <ranma+openwrt@tdiedrich.de>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+
+#include <linux/rtl8366.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define WL351_GPIO_LED_POWER_AMBER 8
+#define WL351_GPIO_LED_UNPOPULATED_AMBER 12
+#define WL351_GPIO_LED_UNPOPULATED_BLUE 13
+
+#define WL351_GPIO_BUTTON_RESET 10
+#define WL351_GPIO_BUTTON_WPS 0
+
+#define WL351_BUTTONS_POLL_INTERVAL 20
+
+
+static struct gpio_led wl351_leds_gpio[] __initdata = {
+ {
+ .name = "wl-351:amber:power",
+ .gpio = WL351_GPIO_LED_POWER_AMBER,
+ .active_low = 1,
+ }, {
+ .name = "wl-351:amber:unpopulated",
+ .gpio = WL351_GPIO_LED_UNPOPULATED_AMBER,
+ .active_low = 1,
+ }, {
+ .name = "wl-351:blue:unpopulated",
+ .gpio = WL351_GPIO_LED_UNPOPULATED_BLUE,
+ .active_low = 1,
+ }
+};
+
+
+static struct gpio_button wl351_gpio_buttons[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .threshold = 3,
+ .gpio = WL351_GPIO_BUTTON_RESET,
+ .active_low = 1,
+ }, {
+ .desc = "wps",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .threshold = 3,
+ .gpio = WL351_GPIO_BUTTON_WPS,
+ .active_low = 1,
+ }
+};
+
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition wl351_partitions[] = {
+ {
+ .name = "u-boot",
+ .offset = 0,
+ .size = 0x030000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "u-boot-env",
+ .offset = 0x030000,
+ .size = 0x010000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "factory",
+ .offset = 0x040000,
+ .size = 0x010000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "kernel",
+ .offset = 0x050000,
+ .size = 0x110000,
+ }, {
+ .name = "rootfs",
+ .offset = 0x160000,
+ .size = 0x230000,
+ }, {
+ .name = "user (jffs2)",
+ .offset = 0x3F0000,
+ .size = 0x010000,
+ }, {
+ .name = "firmware",
+ .offset = 0x050000,
+ .size = 0x3a0000,
+ }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data wl351_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+ .nr_parts = ARRAY_SIZE(wl351_partitions),
+ .parts = wl351_partitions,
+#endif
+};
+
+
+static struct rtl8366_platform_data wl351_switch_data = {
+ .gpio_sda = RT305X_GPIO_I2C_SD,
+ .gpio_sck = RT305X_GPIO_I2C_SCLK,
+};
+
+static struct platform_device wl351_switch = {
+ .name = RTL8366RB_DRIVER_NAME,
+ .id = -1,
+ .dev = {
+ .platform_data = &wl351_switch_data,
+ }
+};
+
+static void __init wl351_init(void)
+{
+ rt305x_gpio_init((RT305X_GPIO_MODE_GPIO <<
+ RT305X_GPIO_MODE_UART0_SHIFT) |
+ RT305X_GPIO_MODE_I2C |
+ RT305X_GPIO_MODE_SPI |
+ RT305X_GPIO_MODE_MDIO);
+ rt305x_register_flash(0, &wl351_flash_data);
+ ramips_register_gpio_leds(-1, ARRAY_SIZE(wl351_leds_gpio),
+ wl351_leds_gpio);
+ ramips_register_gpio_buttons(-1, WL351_BUTTONS_POLL_INTERVAL,
+ ARRAY_SIZE(wl351_gpio_buttons),
+ wl351_gpio_buttons);
+ // external rtl8366rb
+ rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_BYPASS;
+ rt305x_esw_data.reg_initval_fct2 = 0x0002500c;
+ rt305x_esw_data.reg_initval_fpa2 = 0x1f003fff;
+ rt305x_register_ethernet();
+ platform_device_register(&wl351_switch);
+ rt305x_register_wifi();
+ rt305x_register_wdt();
+ rt305x_register_usb();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_WL351, "WL-351", "Sitecom WL-351 v1 002",
+ wl351_init);
diff --git a/target/linux/ramips/files/drivers/net/ramips_esw.c b/target/linux/ramips/files/drivers/net/ramips_esw.c
index 027284b084..a2fa579d8b 100644
--- a/target/linux/ramips/files/drivers/net/ramips_esw.c
+++ b/target/linux/ramips/files/drivers/net/ramips_esw.c
@@ -218,7 +218,7 @@ rt305x_esw_hw_init(struct rt305x_esw *esw)
(RT305X_ESW_PORTS_NOCPU << RT305X_ESW_POC3_UNTAG_EN_S)),
RT305X_ESW_REG_POC3);
- rt305x_esw_wr(esw, 0x00d6500c, RT305X_ESW_REG_FCT2);
+ rt305x_esw_wr(esw, esw->pdata->reg_initval_fct2, RT305X_ESW_REG_FCT2);
rt305x_esw_wr(esw, 0x0008a301, RT305X_ESW_REG_SGC);
/* Setup SoC Port control register */
@@ -229,7 +229,7 @@ rt305x_esw_hw_init(struct rt305x_esw *esw)
(RT305X_ESW_PORTS_CPU << RT305X_ESW_SOCPC_DISBC2CPU_S)),
RT305X_ESW_REG_SOCPC);
- rt305x_esw_wr(esw, 0x3f502b28, RT305X_ESW_REG_FPA2);
+ rt305x_esw_wr(esw, esw->pdata->reg_initval_fpa2, RT305X_ESW_REG_FPA2);
rt305x_esw_wr(esw, 0x00000000, RT305X_ESW_REG_FPA);
/* Force Link/Activity on ports */
@@ -277,6 +277,18 @@ rt305x_esw_hw_init(struct rt305x_esw *esw)
case RT305X_ESW_VLAN_CONFIG_NONE:
break;
+ case RT305X_ESW_VLAN_CONFIG_BYPASS:
+ /* Pass all vlan tags to all ports */
+ for (i = 0; i < RT305X_ESW_NUM_VLANS; i++) {
+ rt305x_esw_set_vlan_id(esw, i, i+1);
+ rt305x_esw_set_vmsc(esw, i, RT305X_ESW_PORTS_ALL);
+ }
+ /* Disable VLAN TAG removal, keep aging on. */
+ rt305x_esw_wr(esw,
+ RT305X_ESW_PORTS_ALL << RT305X_ESW_POC3_ENAGING_S,
+ RT305X_ESW_REG_POC3);
+ break;
+
case RT305X_ESW_VLAN_CONFIG_LLLLW:
rt305x_esw_set_vlan_id(esw, 0, 1);
rt305x_esw_set_vlan_id(esw, 1, 2);
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 12487854d5..8f4e211255 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -179,6 +179,10 @@ define Image/Build/Profile/NBG419N
$(call Image/Build/Template/GENERIC_4M,$(1),nbg-419n,NBG-419N)
endef
+define Image/Build/Profile/WL351
+ $(call Image/Build/Template/GENERIC_4M,$(1),wl-351,WL-351)
+endef
+
define Image/Build/Profile/NW718
$(call Image/Build/Template/NW718,$(1),nw718,NW718)
endef
@@ -271,6 +275,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/HW5503G,$(1))
$(call Image/Build/Profile/MOFI35003GN,$(1))
$(call Image/Build/Profile/WR5123GN,$(1))
+ $(call Image/Build/Profile/WL351,$(1))
endef
endif
diff --git a/target/linux/ramips/rt305x/config-2.6.39 b/target/linux/ramips/rt305x/config-2.6.39
index 2a5473dfb2..68d9a23693 100644
--- a/target/linux/ramips/rt305x/config-2.6.39
+++ b/target/linux/ramips/rt305x/config-2.6.39
@@ -107,6 +107,7 @@ CONFIG_RT305X_MACH_RT_G32_REVB=y
CONFIG_RT305X_MACH_V22RW_2X2=y
CONFIG_RT305X_MACH_WCR150GN=y
CONFIG_RT305X_MACH_WHR_G300N=y
+CONFIG_RT305X_MACH_WL351=y
CONFIG_RT305X_MACH_WR512_3GN=y
# CONFIG_SCSI_DMA is not set
CONFIG_SERIAL_8250_NR_UARTS=4