aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-12-23 14:27:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-12-23 14:27:10 +0000
commit2cb946f5b4ebb720739b4dbb80c7821843f22ee5 (patch)
treee47c13a3c4236f3b7972ea14405b1afc5f7d1708 /target
parent03bce343840c3936cce79e42a8e6973870807aea (diff)
downloadupstream-2cb946f5b4ebb720739b4dbb80c7821843f22ee5.tar.gz
upstream-2cb946f5b4ebb720739b4dbb80c7821843f22ee5.tar.bz2
upstream-2cb946f5b4ebb720739b4dbb80c7821843f22ee5.zip
ramips: add support for the Senao/EnGenius ESR-9753 board
Signed-off-by: Artur Wronowski <arteqw@gmail.com> SVN-Revision: 29603
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/diag.sh3
-rw-r--r--target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom1
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/leds17
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/network1
-rw-r--r--target/linux/ramips/base-files/lib/preinit/06_set_iface_mac2
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rw-r--r--target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig5
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/mach-esr-9753.c123
-rw-r--r--target/linux/ramips/files/drivers/net/ramips_esw.c12
-rw-r--r--target/linux/ramips/image/Makefile5
-rw-r--r--target/linux/ramips/rt305x/config-2.6.391
-rw-r--r--target/linux/ramips/rt305x/profiles/engenius.mk16
14 files changed, 190 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index e0a4a39218..a150cc26d8 100755
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -33,6 +33,9 @@ get_status_led() {
dir-300-b1 | dir-600-b1 | dir-600-b2)
status_led="d-link:green:status"
;;
+ esr-9753)
+ status_led="esr-9753:orange:power"
+ ;;
fonera20n)
status_led="fonera20n:green:power"
;;
diff --git a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
index d6db35c044..fa6607fd7f 100644
--- a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
+++ b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
@@ -47,6 +47,7 @@ case "$FIRMWARE" in
argus-atp52b | \
bc2 | \
+ esr-9753 | \
fonera20n | \
hw550-3g | \
mofi3500-3gn | \
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/leds b/target/linux/ramips/base-files/etc/uci-defaults/leds
index e6c7e8456e..d0a9ac0711 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/leds
+++ b/target/linux/ramips/base-files/etc/uci-defaults/leds
@@ -16,12 +16,29 @@ commit system
EOF
}
+set_wifi_led() {
+ local sysfs="$1"
+
+ uci batch <<EOF
+set system.wifi_led=led
+set system.wifi_led.name='wifi'
+set system.wifi_led.sysfs='$sysfs'
+set system.wifi_led.trigger='netdev'
+set system.wifi_led.dev='wlan0'
+set system.wifi_led.mode='link rx tx'
+commit system
+EOF
+}
+
board=$(ramips_board_name)
case $board in
bc2)
set_usb_led "bc2:blue:usb"
;;
+ esr-9753)
+ set_wifi_led "rt2800pci-phy0::radio"
+ ;;
fonera20n)
set_usb_led "fonera20n:amber:usb"
;;
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/network b/target/linux/ramips/base-files/etc/uci-defaults/network
index f78f9bf9dc..bb1d90ef48 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/network
+++ b/target/linux/ramips/base-files/etc/uci-defaults/network
@@ -68,6 +68,7 @@ ramips_setup_macs()
wan_mac=$(/usr/sbin/maccalc add "$lan_mac" 1)
;;
+ esr-9753 | \
nbg-419n)
lan_mac=$(ramips_get_mac_binary factory 4)
wan_mac=$(ramips_get_mac_binary factory 40)
diff --git a/target/linux/ramips/base-files/lib/preinit/06_set_iface_mac b/target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
index 0518b7be94..eade567c39 100644
--- a/target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
+++ b/target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
@@ -8,7 +8,7 @@ preinit_set_mac_address() {
. /lib/ramips.sh
case $(ramips_board_name) in
- bc2 | nw718)
+ bc2 | nw718 | esr-9753)
mac=$(ramips_get_mac_binary factory 4)
mac=$(maccalc or "$mac" "02:00:00:00:00:00")
ifconfig eth0 hw ether $mac 2>/dev/null
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 7d45bde096..faed42162c 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -62,6 +62,9 @@ ramips_board_name() {
*"DIR-600 B2")
name="dir-600-b2"
;;
+ *"ESR-9753")
+ name="esr-9753"
+ ;;
*"F5D8235 v2")
name="f5d8235-v2"
;;
diff --git a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
index 211f72c5bc..4076d6c500 100644
--- a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
+++ b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
@@ -27,6 +27,7 @@ enum ramips_mach_type {
/* RT3052 based machines */
RAMIPS_MACH_ARGUS_ATP52B, /* Argus ATP-52B */
RAMIPS_MACH_BC2, /* NexAira BC2 */
+ RAMIPS_MACH_ESR_9753, /* Senao / EnGenius ESR-9753*/
RAMIPS_MACH_F5D8235_V2, /* Belkin F5D8235 v2 */
RAMIPS_MACH_FONERA20N, /* La Fonera 2.0N */
RAMIPS_MACH_HW550_3G, /* Aztech HW550-3G */
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
index cf8ede3b6b..3e58242161 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
@@ -31,6 +31,11 @@ config RT305X_MACH_DIR_300_REVB
select RALINK_DEV_GPIO_BUTTONS
select RALINK_DEV_GPIO_LEDS
+config RT305X_MACH_ESR_9753
+ bool "EnGenius ESR-9753 support"
+ select RALINK_DEV_GPIO_BUTTONS
+ select RALINK_DEV_GPIO_LEDS
+
config RT305X_MACH_FONERA20N
bool "La Fonera20N board support"
select RALINK_DEV_GPIO_BUTTONS
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
index be3d308f2d..5da73155f9 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
@@ -14,6 +14,7 @@ obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
obj-$(CONFIG_RT305X_MACH_ARGUS_ATP52B) += mach-argus-atp52b.o
obj-$(CONFIG_RT305X_MACH_BC2) += mach-bc2.o
obj-$(CONFIG_RT305X_MACH_DIR_300_REVB) += mach-dir-300-revb.o
+obj-$(CONFIG_RT305X_MACH_ESR_9753) += mach-esr-9753.o
obj-$(CONFIG_RT305X_MACH_F5D8235_V2) += mach-f5d8235-v2.o
obj-$(CONFIG_RT305X_MACH_FONERA20N) += mach-fonera20n.o
obj-$(CONFIG_RT305X_MACH_HW550_3G) += mach-hw550-3g.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-esr-9753.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-esr-9753.c
new file mode 100644
index 0000000000..88043a01d7
--- /dev/null
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-esr-9753.c
@@ -0,0 +1,123 @@
+/*
+ * Senao / EnGenius ESR-9753 board support
+ *
+ * Copyright (C) 2011 Artur Wronowski <arteqw@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define ESR_9753_GPIO_LED_POWER 8
+#define ESR_9753_GPIO_LED_WPS 14
+
+#define ESR_9753_GPIO_BUTTON_WPS 0 /* active low */
+#define ESR_9753_GPIO_BUTTON_RESET 10 /* active low */
+
+#define ESR_9753_BUTTONS_POLL_INTERVAL 20
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition esr_9753_partitions[] = {
+ {
+ .name = "u-boot",
+ .offset = 0,
+ .size = 0x030000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "u-boot-env",
+ .offset = 0x030000,
+ .size = 0x010000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "factory",
+ .offset = 0x040000,
+ .size = 0x010000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "kernel",
+ .offset = 0x050000,
+ .size = 0x0a0000,
+ }, {
+ .name = "rootfs",
+ .offset = 0x150000,
+ .size = 0x2b0000,
+ }, {
+ .name = "firmware",
+ .offset = 0x050000,
+ .size = 0x3b0000,
+ }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data esr_9753_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+ .nr_parts = ARRAY_SIZE(esr_9753_partitions),
+ .parts = esr_9753_partitions,
+#endif
+};
+
+static struct gpio_led esr_9753_leds_gpio[] __initdata = {
+ {
+ .name = "esr-9753:orange:power",
+ .gpio = ESR_9753_GPIO_LED_POWER,
+ .active_low = 1,
+ }, {
+ .name = "esr-9753:orange:wps",
+ .gpio = ESR_9753_GPIO_LED_WPS,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_button esr_9753_gpio_buttons[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .threshold = 3,
+ .gpio = ESR_9753_GPIO_BUTTON_RESET,
+ .active_low = 1,
+ }, {
+ .desc = "wps",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .threshold = 3,
+ .gpio = ESR_9753_GPIO_BUTTON_WPS,
+ .active_low = 1,
+ }
+};
+
+static void __init esr_9753_init(void)
+{
+ rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+
+ rt305x_register_flash(0, &esr_9753_flash_data);
+
+ ramips_register_gpio_leds(-1, ARRAY_SIZE(esr_9753_leds_gpio),
+ esr_9753_leds_gpio);
+
+ ramips_register_gpio_buttons(-1, ESR_9753_BUTTONS_POLL_INTERVAL,
+ ARRAY_SIZE(esr_9753_gpio_buttons),
+ esr_9753_gpio_buttons);
+
+ rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_WLLLL;
+ rt305x_register_ethernet();
+ rt305x_register_wifi();
+ rt305x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_ESR_9753, "ESR-9753", "Senao / EnGenius ESR-9753",
+ esr_9753_init);
diff --git a/target/linux/ramips/files/drivers/net/ramips_esw.c b/target/linux/ramips/files/drivers/net/ramips_esw.c
index c681eed830..027284b084 100644
--- a/target/linux/ramips/files/drivers/net/ramips_esw.c
+++ b/target/linux/ramips/files/drivers/net/ramips_esw.c
@@ -19,6 +19,11 @@
#define RT305X_ESW_REG_FPA2 0xc8
#define RT305X_ESW_REG_FCT2 0xcc
#define RT305X_ESW_REG_SGC2 0xe4
+#define RT305X_ESW_REG_P0LED 0xa4
+#define RT305X_ESW_REG_P1LED 0xa8
+#define RT305X_ESW_REG_P2LED 0xac
+#define RT305X_ESW_REG_P3LED 0xb0
+#define RT305X_ESW_REG_P4LED 0xb4
#define RT305X_ESW_PCR0_WT_NWAY_DATA_S 16
#define RT305X_ESW_PCR0_WT_PHY_CMD BIT(13)
@@ -227,6 +232,13 @@ rt305x_esw_hw_init(struct rt305x_esw *esw)
rt305x_esw_wr(esw, 0x3f502b28, RT305X_ESW_REG_FPA2);
rt305x_esw_wr(esw, 0x00000000, RT305X_ESW_REG_FPA);
+ /* Force Link/Activity on ports */
+ rt305x_esw_wr(esw, 0x00000005, RT305X_ESW_REG_P0LED);
+ rt305x_esw_wr(esw, 0x00000005, RT305X_ESW_REG_P1LED);
+ rt305x_esw_wr(esw, 0x00000005, RT305X_ESW_REG_P2LED);
+ rt305x_esw_wr(esw, 0x00000005, RT305X_ESW_REG_P3LED);
+ rt305x_esw_wr(esw, 0x00000005, RT305X_ESW_REG_P4LED);
+
rt305x_mii_write(esw, 0, 31, 0x8000);
for (i = 0; i < 5; i++) {
/* TX10 waveform coefficient */
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 4f92d30ecd..12487854d5 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -162,6 +162,10 @@ define Image/Build/Profile/RTG32B1
$(call Image/Build/Template/RTG32B1,$(1),rt-g32-b1,RT-G32-B1)
endef
+define Image/Build/Profile/ESR9753
+ $(call Image/Build/Template/GENERIC_4M,$(1),esr-9753,ESR-9753)
+endef
+
define Image/Build/Profile/FONERA20N
$(call Image/Build/Template/GENERIC_8M,$(1),fonera20n,FONERA20N)
$(call BuildFirmware/Edimax,$(1),fonera20n,RSDK,NL1T,0x50000,0xc0000)
@@ -253,6 +257,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/ARGUS_ATP52B,$(1))
$(call Image/Build/Profile/BC2,$(1))
$(call Image/Build/Profile/DIR300B1,$(1))
+ $(call Image/Build/Profile/ESR9753,$(1))
$(call Image/Build/Profile/RTG32B1,$(1))
$(call Image/Build/Profile/FONERA20N,$(1))
$(call Image/Build/Profile/V22RW2X2,$(1))
diff --git a/target/linux/ramips/rt305x/config-2.6.39 b/target/linux/ramips/rt305x/config-2.6.39
index e3553e1efb..2a5473dfb2 100644
--- a/target/linux/ramips/rt305x/config-2.6.39
+++ b/target/linux/ramips/rt305x/config-2.6.39
@@ -94,6 +94,7 @@ CONFIG_RAMIPS_WDT=y
CONFIG_RT305X_MACH_ARGUS_ATP52B=y
CONFIG_RT305X_MACH_BC2=y
CONFIG_RT305X_MACH_DIR_300_REVB=y
+CONFIG_RT305X_MACH_ESR_9753=y
CONFIG_RT305X_MACH_F5D8235_V2=y
CONFIG_RT305X_MACH_FONERA20N=y
CONFIG_RT305X_MACH_HW550_3G=y
diff --git a/target/linux/ramips/rt305x/profiles/engenius.mk b/target/linux/ramips/rt305x/profiles/engenius.mk
new file mode 100644
index 0000000000..09c716ecd9
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/engenius.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ESR9753
+ NAME:=EnGenius Profile
+ PACKAGES:=
+endef
+
+define Profile/ESR9753/Description
+ EnGenius profile.
+endef
+$(eval $(call Profile,ESR9753))