aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2017-05-05 18:07:04 +0200
committerMathias Kresin <dev@kresin.me>2017-05-05 20:02:19 +0200
commit64f2efcdff0f0e3d030340f2bb8fc7e5f6cae5b1 (patch)
tree9fbc52528ec473ca39f19b3cd2f6e9ab43df4c01 /target
parentcfdd3f260e13d78feb232831c220e190e927c290 (diff)
downloadupstream-64f2efcdff0f0e3d030340f2bb8fc7e5f6cae5b1.tar.gz
upstream-64f2efcdff0f0e3d030340f2bb8fc7e5f6cae5b1.tar.bz2
upstream-64f2efcdff0f0e3d030340f2bb8fc7e5f6cae5b1.zip
ramips: strip padding from TP-Link sysupgrade images
This reduce size of sysupgrade firmware. Signed-off-by: Henryk Heisig <hyniu@o2.pl>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/mt7620.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index f0710e68af..5f7798f029 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -34,7 +34,7 @@ define Device/ArcherC20i
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC20i -c
IMAGE/factory.bin := append-kernel | tplink-header ArcherC20i -j
- IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC20i -j | append-metadata
+ IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC20i -j -s | append-metadata
IMAGES += factory.bin
DEVICE_TITLE := TP-Link ArcherC20i
endef
@@ -46,7 +46,7 @@ define Device/ArcherC50
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC50 -c
IMAGE/factory.bin := append-kernel | tplink-header ArcherC50 -j
- IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC50 -j | append-metadata
+ IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC50 -j -s | append-metadata
IMAGES += factory.bin
DEVICE_TITLE := TP-Link ArcherC50
endef
@@ -57,7 +57,7 @@ define Device/ArcherMR200
SUPPORTED_DEVICES := mr200
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherMR200 -c
- IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherMR200 -j | append-metadata
+ IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherMR200 -j -s | append-metadata
DEVICE_PACKAGES := kmod-usb2 kmod-usb-net kmod-usb-net-rndis kmod-usb-serial kmod-usb-serial-option adb
DEVICE_TITLE := TP-Link ArcherMR200
endef