aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2017-05-05 17:07:28 +0200
committerMathias Kresin <dev@kresin.me>2017-05-05 20:01:28 +0200
commitcfdd3f260e13d78feb232831c220e190e927c290 (patch)
tree9306ba642067248fd03d24c189021ef6ac08c8bb /target
parent063ee9d0bd2df72a16d86fc39897b084433bd4f3 (diff)
downloadupstream-cfdd3f260e13d78feb232831c220e190e927c290.tar.gz
upstream-cfdd3f260e13d78feb232831c220e190e927c290.tar.bz2
upstream-cfdd3f260e13d78feb232831c220e190e927c290.zip
ramips: add factory firmware for Tp-Link C20i/C50
TP-Link firmware doesn't accept sysupgrade.bin with metadata. Signed-off-by: Henryk Heisig <hyniu@o2.pl>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/mt7620.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 71b651cda6..f0710e68af 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -33,7 +33,9 @@ define Device/ArcherC20i
SUPPORTED_DEVICES := c20i
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC20i -c
+ IMAGE/factory.bin := append-kernel | tplink-header ArcherC20i -j
IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC20i -j | append-metadata
+ IMAGES += factory.bin
DEVICE_TITLE := TP-Link ArcherC20i
endef
TARGET_DEVICES += ArcherC20i
@@ -43,7 +45,9 @@ define Device/ArcherC50
SUPPORTED_DEVICES := c50
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC50 -c
+ IMAGE/factory.bin := append-kernel | tplink-header ArcherC50 -j
IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC50 -j | append-metadata
+ IMAGES += factory.bin
DEVICE_TITLE := TP-Link ArcherC50
endef
TARGET_DEVICES += ArcherC50