aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-11-25 16:16:19 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-11-25 16:16:19 +0000
commit559d009b2b55b8d545395ce3481927f48ca0ab1c (patch)
treee1befee98a71df7e38a00d2ac904aec126848274 /target
parented487974805b93442a5d26f0e7cdbedf3bbc9ad0 (diff)
downloadupstream-559d009b2b55b8d545395ce3481927f48ca0ab1c.tar.gz
upstream-559d009b2b55b8d545395ce3481927f48ca0ab1c.tar.bz2
upstream-559d009b2b55b8d545395ce3481927f48ca0ab1c.zip
AA: scripts/om-fwupgradecfg-gen.sh: add support for the MR600
Backport of r34233. Signed-off-by: Marek Lindner <lindner_marek@yahoo.de> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@34348 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d3d483d88f..e212348509 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -681,12 +681,13 @@ endif
define Image/Build/OpenMesh
$(call MkuImageLzma,$(2))
-sh $(TOPDIR)/scripts/om-fwupgradecfg-gen.sh \
- "$(BUILD_DIR)/om2p-fwupgrade.cfg" \
+ "$(4)" \
+ "$(BUILD_DIR)/fwupgrade.cfg-$(4)" \
"$(KDIR_TMP)/vmlinux-$(2).uImage" \
"$(KDIR)/root.$(1)"
-sh $(TOPDIR)/scripts/combined-ext-image.sh \
"$(4)" "$(call factoryname,$(1),$(2))" \
- "$(BUILD_DIR)/om2p-fwupgrade.cfg" "fwupgrade.cfg" \
+ "$(BUILD_DIR)/fwupgrade.cfg-$(4)" "fwupgrade.cfg" \
"$(KDIR_TMP)/vmlinux-$(2).uImage" "kernel" \
"$(KDIR)/root.$(1)" "rootfs"
endef