aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-04-21 16:34:39 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-21 16:34:39 +0200
commit484cb91ad597c1a1019355b773a588d6e7f45a8d (patch)
treee8acf3b2f3bd9143ac164a196d63a8b28168956d /target/sdk
parent1191eeff8ec86850a5a952987816823359f37793 (diff)
downloadupstream-484cb91ad597c1a1019355b773a588d6e7f45a8d.tar.gz
upstream-484cb91ad597c1a1019355b773a588d6e7f45a8d.tar.bz2
upstream-484cb91ad597c1a1019355b773a588d6e7f45a8d.zip
sdk: bundle required firmware files
Bundle all firmware files which have been built along with the kernel to fix packaging of kmods in the SDK environment that rely on in-tree firmwares, specifically kmod-e100. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 7f277f9aff..f32b02b536 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -70,6 +70,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
$(CP) $(INCLUDE_DIR) $(SCRIPT_DIR) $(TOPDIR)/docs $(SDK_BUILD_DIR)/
$(TAR) -cf - -C $(TOPDIR) \
`cd $(TOPDIR); find $(KDIR_BASE) -name \*.ko` \
+ `cd $(TOPDIR); find $(KDIR_BASE)/firmware/ -newer $(KDIR_BASE)/firmware/Makefile \
+ -type f -name '*.bin' -or -name '*.cis' -or -name '*.csp' -or -name '*.dsp' -or -name '*.fw'` \
$(foreach exclude,$(EXCLUDE_DIRS),--exclude="$(exclude)") \
$(SDK_DIRS) $(KERNEL_FILES) | \
$(TAR) -xf - -C $(SDK_BUILD_DIR)