aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/sdk/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 7f277f9aff..f32b02b536 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -70,6 +70,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
$(CP) $(INCLUDE_DIR) $(SCRIPT_DIR) $(TOPDIR)/docs $(SDK_BUILD_DIR)/
$(TAR) -cf - -C $(TOPDIR) \
`cd $(TOPDIR); find $(KDIR_BASE) -name \*.ko` \
+ `cd $(TOPDIR); find $(KDIR_BASE)/firmware/ -newer $(KDIR_BASE)/firmware/Makefile \
+ -type f -name '*.bin' -or -name '*.cis' -or -name '*.csp' -or -name '*.dsp' -or -name '*.fw'` \
$(foreach exclude,$(EXCLUDE_DIRS),--exclude="$(exclude)") \
$(SDK_DIRS) $(KERNEL_FILES) | \
$(TAR) -xf - -C $(SDK_BUILD_DIR)