aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-01-13 21:37:47 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-17 18:22:40 +0100
commitbb0e4f9fb0c101b86b1a0c2785fec9b38b19fd02 (patch)
tree4dbaf2b7c50756927af6fa267293a369c8d250e4 /target/linux/x86/image/Makefile
parentda50f027f04e52b152c6e197d2d4a70330669a36 (diff)
downloadupstream-bb0e4f9fb0c101b86b1a0c2785fec9b38b19fd02.tar.gz
upstream-bb0e4f9fb0c101b86b1a0c2785fec9b38b19fd02.tar.bz2
upstream-bb0e4f9fb0c101b86b1a0c2785fec9b38b19fd02.zip
build: remove leftovers from previous x86 commits
VBoxManage is not used and the image is created with proper permisions: 0f5d0f6 image: use internal qemu-img for vmdk and vdi images drop host dependencies on qemu-utils and VirtualBox Unreachable config symbols: 9e0759e x86: merge all geode based subtargets into one No need to define those symbols since x86_64 is subtarget of x86: 196fb76 x86: make x86_64 a subtarget instead of a standalone target Unreachable config symbols, so remove GRUB_ROOT: 371b382 x86: remove the xen_domu subtarget Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile8
1 files changed, 0 insertions, 8 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index dbf8a8594b..d799a0ba03 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -15,7 +15,6 @@ GRUB_TERMINALS =
GRUB_SERIAL_CONFIG =
GRUB_TERMINAL_CONFIG =
GRUB_CONSOLE_CMDLINE =
-GRUB_ROOT = hd0,msdos1
USE_ATKBD = generic 64
@@ -48,10 +47,6 @@ ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(SIGNATURE)-02)
GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_GRUB_TIMEOUT))
GRUB_TITLE:=$(call qstrip,$(CONFIG_GRUB_TITLE))
-ifneq ($(CONFIG_TARGET_x86_xen_domu),)
- GRUB_ROOT = xen/xvda,msdos1
-endif
-
ifneq ($(CONFIG_GRUB_IMAGES),)
BOOTOPTS:=$(call qstrip,$(CONFIG_GRUB_BOOTOPTS))
@@ -82,7 +77,6 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
-e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
-e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
-e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
- -e 's#@ROOT@#$(GRUB_ROOT)#g' \
-e 's#@TITLE@#$(GRUB_TITLE)#g' \
./grub.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
-$(CP) $(STAGING_DIR_ROOT)/boot/. $(KDIR)/root.grub/boot/
@@ -135,8 +129,6 @@ ifneq ($(CONFIG_VDI_IMAGES),)
qemu-img convert -f raw -O vdi \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
- # XXX: VBoxManage insists on setting perms to 0600
- chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
endef
endif