aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config/Config-images.in9
-rw-r--r--package/boot/grub2/Makefile4
-rw-r--r--target/linux/x86/image/Makefile8
-rw-r--r--target/linux/x86/image/grub.cfg2
4 files changed, 6 insertions, 17 deletions
diff --git a/config/Config-images.in b/config/Config-images.in
index bdd24ef617..6610601d55 100644
--- a/config/Config-images.in
+++ b/config/Config-images.in
@@ -197,14 +197,12 @@ menu "Target Images"
config GRUB_CONSOLE
bool "Use Console Terminal (in addition to Serial)"
depends on GRUB_IMAGES
- default n if (TARGET_x86_generic_Soekris45xx || TARGET_x86_generic_Soekris48xx || TARGET_x86_net5501 || TARGET_x86_geos || TARGET_x86_alix2)
default y
config GRUB_SERIAL
string "Serial port device"
depends on GRUB_IMAGES
- default "hvc0" if TARGET_x86_xen_domu
- default "ttyS0" if ! TARGET_x86_xen_domu
+ default "ttyS0"
config GRUB_BAUDRATE
int "Serial port baud rate"
@@ -220,7 +218,6 @@ menu "Target Images"
config GRUB_BOOTOPTS
string "Extra kernel boot options"
depends on GRUB_IMAGES
- default "xencons=hvc" if TARGET_x86_xen_domu
help
If you don't know, just leave it blank.
@@ -241,14 +238,14 @@ menu "Target Images"
config VDI_IMAGES
bool "Build VirtualBox image files (VDI)"
- depends on TARGET_x86 || TARGET_x86_64
+ depends on TARGET_x86
select GRUB_IMAGES
select TARGET_IMAGES_PAD
select PACKAGE_kmod-e1000
config VMDK_IMAGES
bool "Build VMware image files (VMDK)"
- depends on TARGET_x86 || TARGET_x86_64
+ depends on TARGET_x86
select GRUB_IMAGES
select TARGET_IMAGES_PAD
select PACKAGE_kmod-e1000
diff --git a/package/boot/grub2/Makefile b/package/boot/grub2/Makefile
index e4c19cd00f..d6af65128e 100644
--- a/package/boot/grub2/Makefile
+++ b/package/boot/grub2/Makefile
@@ -33,7 +33,7 @@ define Package/grub2
SECTION:=boot
TITLE:=GRand Unified Bootloader
URL:=http://www.gnu.org/software/grub/
- DEPENDS:=@TARGET_x86||TARGET_x86_64
+ DEPENDS:=@TARGET_x86
endef
define Package/grub2-editenv
@@ -42,7 +42,7 @@ define Package/grub2-editenv
SUBMENU:=Boot Loaders
TITLE:=Grub2 Environment editor
URL:=http://www.gnu.org/software/grub/
- DEPENDS:=@TARGET_x86||TARGET_x86_64
+ DEPENDS:=@TARGET_x86
endef
define Package/grub2-editenv/description
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index dbf8a8594b..d799a0ba03 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -15,7 +15,6 @@ GRUB_TERMINALS =
GRUB_SERIAL_CONFIG =
GRUB_TERMINAL_CONFIG =
GRUB_CONSOLE_CMDLINE =
-GRUB_ROOT = hd0,msdos1
USE_ATKBD = generic 64
@@ -48,10 +47,6 @@ ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(SIGNATURE)-02)
GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_GRUB_TIMEOUT))
GRUB_TITLE:=$(call qstrip,$(CONFIG_GRUB_TITLE))
-ifneq ($(CONFIG_TARGET_x86_xen_domu),)
- GRUB_ROOT = xen/xvda,msdos1
-endif
-
ifneq ($(CONFIG_GRUB_IMAGES),)
BOOTOPTS:=$(call qstrip,$(CONFIG_GRUB_BOOTOPTS))
@@ -82,7 +77,6 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
-e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
-e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
-e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
- -e 's#@ROOT@#$(GRUB_ROOT)#g' \
-e 's#@TITLE@#$(GRUB_TITLE)#g' \
./grub.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
-$(CP) $(STAGING_DIR_ROOT)/boot/. $(KDIR)/root.grub/boot/
@@ -135,8 +129,6 @@ ifneq ($(CONFIG_VDI_IMAGES),)
qemu-img convert -f raw -O vdi \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
- # XXX: VBoxManage insists on setting perms to 0600
- chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
endef
endif
diff --git a/target/linux/x86/image/grub.cfg b/target/linux/x86/image/grub.cfg
index dedfa0a636..76a9885544 100644
--- a/target/linux/x86/image/grub.cfg
+++ b/target/linux/x86/image/grub.cfg
@@ -3,7 +3,7 @@
set default="0"
set timeout="@TIMEOUT@"
-set root='(@ROOT@)'
+set root='(hd0,msdos1)'
menuentry "@TITLE@" {
linux /boot/vmlinuz @CMDLINE@ noinitrd