aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2019-10-08 15:42:18 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-10-11 17:45:02 +0200
commit37e62ec4ec811cb6d2c8c0b25202ad551e035413 (patch)
treea13df205d0a6baa0adb8be00d911b9e08cbe6980 /target/linux/sunxi
parent4943d3f14bafc9b6ff798711b676a089eb1051a4 (diff)
downloadupstream-37e62ec4ec811cb6d2c8c0b25202ad551e035413.tar.gz
upstream-37e62ec4ec811cb6d2c8c0b25202ad551e035413.tar.bz2
upstream-37e62ec4ec811cb6d2c8c0b25202ad551e035413.zip
sunxi: add a kmod package for sun4i_spdif
Tested on a A20 board: $ cat /proc/asound/cards 0 [SPDIF ]: On-board_SPDIF - On-board SPDIF On-board SPDIF Size of the module for a 32bit kernel: 60708 linux-5.4.66/sound/soc/sunxi/sun4i-spdif.ko Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/modules.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index b8ea7d5cb6..6d2de98658 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -68,7 +68,6 @@ endef
$(eval $(call KernelPackage,sun4i-emac))
-
define KernelPackage/sound-soc-sunxi
TITLE:=AllWinner built-in SoC sound support
KCONFIG:=CONFIG_SND_SUN4I_CODEC
@@ -83,3 +82,18 @@ define KernelPackage/sound-soc-sunxi/description
endef
$(eval $(call KernelPackage,sound-soc-sunxi))
+
+define KernelPackage/sound-soc-sunxi-spdif
+ TITLE:=Allwinner A10 SPDIF Support
+ KCONFIG:=CONFIG_SND_SUN4I_SPDIF
+ FILES:=$(LINUX_DIR)/sound/soc/sunxi/sun4i-spdif.ko
+ AUTOLOAD:=$(call AutoLoad,65,sun4i-spdif)
+ DEPENDS:=@TARGET_sunxi +kmod-sound-soc-spdif
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-sunxi-spdif/description
+ Kernel support for Allwinner A10 SPDIF Support
+endef
+
+$(eval $(call KernelPackage,sound-soc-sunxi-spdif))