aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/sunxi/modules.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index b8ea7d5cb6..6d2de98658 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -68,7 +68,6 @@ endef
$(eval $(call KernelPackage,sun4i-emac))
-
define KernelPackage/sound-soc-sunxi
TITLE:=AllWinner built-in SoC sound support
KCONFIG:=CONFIG_SND_SUN4I_CODEC
@@ -83,3 +82,18 @@ define KernelPackage/sound-soc-sunxi/description
endef
$(eval $(call KernelPackage,sound-soc-sunxi))
+
+define KernelPackage/sound-soc-sunxi-spdif
+ TITLE:=Allwinner A10 SPDIF Support
+ KCONFIG:=CONFIG_SND_SUN4I_SPDIF
+ FILES:=$(LINUX_DIR)/sound/soc/sunxi/sun4i-spdif.ko
+ AUTOLOAD:=$(call AutoLoad,65,sun4i-spdif)
+ DEPENDS:=@TARGET_sunxi +kmod-sound-soc-spdif
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-sunxi-spdif/description
+ Kernel support for Allwinner A10 SPDIF Support
+endef
+
+$(eval $(call KernelPackage,sound-soc-sunxi-spdif))