aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image
diff options
context:
space:
mode:
authorJasper Scholte <NightNL@outlook.com>2018-09-19 22:31:26 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-09-22 21:20:55 +0200
commita689307c970e37c247c6452ba3963be8b109eb4f (patch)
tree30b8037a38b5bc496e37fc29aa16b2a02b521565 /target/linux/sunxi/image
parentf57806b56e5f6ca7bb9fb66d5b175b5f98ece93c (diff)
downloadupstream-a689307c970e37c247c6452ba3963be8b109eb4f.tar.gz
upstream-a689307c970e37c247c6452ba3963be8b109eb4f.tar.bz2
upstream-a689307c970e37c247c6452ba3963be8b109eb4f.zip
sunxi: build image/uboot for the NanoPi NEO2
The NanoPi NEO2 is a small Allwinner H5 based board available with different DRAM configurations. This board is very similar to the NanoPi NEO PLUS2 Signed-off-by: Jasper Scholte <NightNL@outlook.com>
Diffstat (limited to 'target/linux/sunxi/image')
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
index e40f35cb32..65551407ce 100644
--- a/target/linux/sunxi/image/cortex-a53.mk
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -17,6 +17,16 @@ endef
TARGET_DEVICES += sun50i-h5-nanopi-neo-plus2
+define Device/sun50i-h5-nanopi-neo2
+ DEVICE_TITLE:=Nanopi NEO2 (H5)
+ SUPPORTED_DEVICES:=nanopi-neo2
+ SUNXI_DTS:=allwinner/sun50i-h5-nanopi-neo2
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+endef
+
+TARGET_DEVICES += sun50i-h5-nanopi-neo2
+
define Device/sun50i-a64-pine64-plus
DEVICE_TITLE:=Pine64 Plus A64
SUPPORTED_DEVICES:=pine64,pine64-plus