aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-sunxi/Makefile9
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk10
2 files changed, 19 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index ce5edfc1b6..b3d9c1eb69 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -182,6 +182,14 @@ define U-Boot/nanopi_neo_plus2
UENV:=a64
endef
+define U-Boot/nanopi_neo2
+ BUILD_SUBTARGET:=cortexa53
+ NAME:=NanoPi NEO2 (H5)
+ BUILD_DEVICES:=sun50i-h5-nanopi-neo2
+ DEPENDS:=+PACKAGE_u-boot-nanopi_neo2:arm-trusted-firmware-sunxi
+ UENV:=a64
+endef
+
define U-Boot/pine64_plus
BUILD_SUBTARGET:=cortexa53
NAME:=Pine64 Plus A64
@@ -237,6 +245,7 @@ UBOOT_TARGETS := \
nanopi_m1_plus \
nanopi_neo \
nanopi_neo_plus2 \
+ nanopi_neo2 \
orangepi_r1 \
orangepi_pc \
orangepi_plus \
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
index e40f35cb32..65551407ce 100644
--- a/target/linux/sunxi/image/cortex-a53.mk
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -17,6 +17,16 @@ endef
TARGET_DEVICES += sun50i-h5-nanopi-neo-plus2
+define Device/sun50i-h5-nanopi-neo2
+ DEVICE_TITLE:=Nanopi NEO2 (H5)
+ SUPPORTED_DEVICES:=nanopi-neo2
+ SUNXI_DTS:=allwinner/sun50i-h5-nanopi-neo2
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+endef
+
+TARGET_DEVICES += sun50i-h5-nanopi-neo2
+
define Device/sun50i-a64-pine64-plus
DEVICE_TITLE:=Pine64 Plus A64
SUPPORTED_DEVICES:=pine64,pine64-plus