aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-07-15 22:53:20 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-09-18 20:34:55 +0200
commit24c2f5125e253d241abed39c59f76b6417f45306 (patch)
tree9d50449b838ffeef183233860a9ebf3bdb96842a /target/linux/sunxi/image
parent3b88f74bbe9134465a84234e1e7400af585f8c2b (diff)
downloadupstream-24c2f5125e253d241abed39c59f76b6417f45306.tar.gz
upstream-24c2f5125e253d241abed39c59f76b6417f45306.tar.bz2
upstream-24c2f5125e253d241abed39c59f76b6417f45306.zip
sunxi: Add A64 support with cortex53 subtarget
This adds initial support for the A64 Allwinner SoC to LEDE. It will be build in the new cortexa53 subtarget. Currently it only supports the pine64 and the image is able to boot on this SoC. Camera, Ethernet, HDMI and other parts are currently not working. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/sunxi/image')
-rw-r--r--target/linux/sunxi/image/Makefile1
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk20
2 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 20ecf66a9c..8f95c61906 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -41,5 +41,6 @@ endef
include cortex-a7.mk
include cortex-a8.mk
+include cortex-a53.mk
$(eval $(call BuildImage))
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
new file mode 100644
index 0000000000..bbb253f0ae
--- /dev/null
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2013-2016 OpenWrt.org
+# Copyright (C) 2016 Yousong Zhou
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+ifeq ($(SUBTARGET),cortexa53)
+
+define Device/sun50i-a64-pine64-plus
+ DEVICE_TITLE:=Pine64 Plus A64
+ SUPPORTED_DEVICES:=pine64,pine64-plus
+ SUNXI_DTS:=allwinner/sun50i-a64-pine64-plus
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+endef
+
+TARGET_DEVICES += sun50i-a64-pine64-plus
+
+endif