aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a53.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/sunxi/image/cortex-a53.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
new file mode 100644
index 0000000000..bbb253f0ae
--- /dev/null
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2013-2016 OpenWrt.org
+# Copyright (C) 2016 Yousong Zhou
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+ifeq ($(SUBTARGET),cortexa53)
+
+define Device/sun50i-a64-pine64-plus
+ DEVICE_TITLE:=Pine64 Plus A64
+ SUPPORTED_DEVICES:=pine64,pine64-plus
+ SUNXI_DTS:=allwinner/sun50i-a64-pine64-plus
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+endef
+
+TARGET_DEVICES += sun50i-a64-pine64-plus
+
+endif