aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a53.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 14:21:19 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 14:21:19 +0100
commitd0d8584b4187da38b484da3290fbb23ca472abad (patch)
treea5b35296fda943018d08784606552ed3825ce3fc /target/linux/sunxi/image/cortex-a53.mk
parenta8723c48add5cc8381d88234b9cdda2bb6a866aa (diff)
downloadupstream-d0d8584b4187da38b484da3290fbb23ca472abad.tar.gz
upstream-d0d8584b4187da38b484da3290fbb23ca472abad.tar.bz2
upstream-d0d8584b4187da38b484da3290fbb23ca472abad.zip
sunxi: tidy up and sort alphabetically in image Makefiles
This tidies up the image Makefiles for the sunxi target by: - Move the if-condition for the subtarget to the parent Makefile - Remove lots of unnecessary empty lines - Sort device definitions alphabetically - Harmonize line wrapping for DEVICE_PACKAGES Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a53.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk22
1 files changed, 6 insertions, 16 deletions
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
index ac82138938..eeaaa887d7 100644
--- a/target/linux/sunxi/image/cortex-a53.mk
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -5,7 +5,6 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-ifeq ($(SUBTARGET),cortexa53)
define Device/friendlyarm_nanopi-neo-plus2
DEVICE_VENDOR := FriendlyARM
@@ -16,7 +15,6 @@ define Device/friendlyarm_nanopi-neo-plus2
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-
TARGET_DEVICES += friendlyarm_nanopi-neo-plus2
define Device/friendlyarm_nanopi-neo2
@@ -28,7 +26,6 @@ define Device/friendlyarm_nanopi-neo2
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-
TARGET_DEVICES += friendlyarm_nanopi-neo2
define Device/pine64_pine64-plus
@@ -39,7 +36,6 @@ define Device/pine64_pine64-plus
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-
TARGET_DEVICES += pine64_pine64-plus
define Device/pine64_sopine-baseboard
@@ -50,30 +46,24 @@ define Device/pine64_sopine-baseboard
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-
TARGET_DEVICES += pine64_sopine-baseboard
-
-define Device/xunlong_orangepi-zero-plus
+define Device/xunlong_orangepi-pc2
DEVICE_VENDOR := Xunlong
- DEVICE_MODEL := Orange Pi Zero Plus
+ DEVICE_MODEL := Orange Pi PC 2
SUNXI_DTS_DIR := allwinner/
SOC := sun50i-h5
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
+TARGET_DEVICES += xunlong_orangepi-pc2
-TARGET_DEVICES += xunlong_orangepi-zero-plus
-
-define Device/xunlong_orangepi-pc2
+define Device/xunlong_orangepi-zero-plus
DEVICE_VENDOR := Xunlong
- DEVICE_MODEL := Orange Pi PC 2
+ DEVICE_MODEL := Orange Pi Zero Plus
SUNXI_DTS_DIR := allwinner/
SOC := sun50i-h5
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-
-TARGET_DEVICES += xunlong_orangepi-pc2
-
-endif
+TARGET_DEVICES += xunlong_orangepi-zero-plus