aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 14:21:19 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 14:21:19 +0100
commitd0d8584b4187da38b484da3290fbb23ca472abad (patch)
treea5b35296fda943018d08784606552ed3825ce3fc
parenta8723c48add5cc8381d88234b9cdda2bb6a866aa (diff)
downloadupstream-d0d8584b4187da38b484da3290fbb23ca472abad.tar.gz
upstream-d0d8584b4187da38b484da3290fbb23ca472abad.tar.bz2
upstream-d0d8584b4187da38b484da3290fbb23ca472abad.zip
sunxi: tidy up and sort alphabetically in image Makefiles
This tidies up the image Makefiles for the sunxi target by: - Move the if-condition for the subtarget to the parent Makefile - Remove lots of unnecessary empty lines - Sort device definitions alphabetically - Harmonize line wrapping for DEVICE_PACKAGES Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--target/linux/sunxi/image/Makefile8
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk22
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk239
-rw-r--r--target/linux/sunxi/image/cortex-a8.mk63
4 files changed, 135 insertions, 197 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 888c1c5a9b..705d409ac5 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -42,8 +42,16 @@ define Device/Default
SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
endef
+ifeq ($(SUBTARGET),cortexa7)
include cortex-a7.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa8)
include cortex-a8.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa53)
include cortex-a53.mk
+endif
$(eval $(call BuildImage))
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
index ac82138938..eeaaa887d7 100644
--- a/target/linux/sunxi/image/cortex-a53.mk
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -5,7 +5,6 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-ifeq ($(SUBTARGET),cortexa53)
define Device/friendlyarm_nanopi-neo-plus2
DEVICE_VENDOR := FriendlyARM
@@ -16,7 +15,6 @@ define Device/friendlyarm_nanopi-neo-plus2
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-
TARGET_DEVICES += friendlyarm_nanopi-neo-plus2
define Device/friendlyarm_nanopi-neo2
@@ -28,7 +26,6 @@ define Device/friendlyarm_nanopi-neo2
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-
TARGET_DEVICES += friendlyarm_nanopi-neo2
define Device/pine64_pine64-plus
@@ -39,7 +36,6 @@ define Device/pine64_pine64-plus
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-
TARGET_DEVICES += pine64_pine64-plus
define Device/pine64_sopine-baseboard
@@ -50,30 +46,24 @@ define Device/pine64_sopine-baseboard
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-
TARGET_DEVICES += pine64_sopine-baseboard
-
-define Device/xunlong_orangepi-zero-plus
+define Device/xunlong_orangepi-pc2
DEVICE_VENDOR := Xunlong
- DEVICE_MODEL := Orange Pi Zero Plus
+ DEVICE_MODEL := Orange Pi PC 2
SUNXI_DTS_DIR := allwinner/
SOC := sun50i-h5
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
+TARGET_DEVICES += xunlong_orangepi-pc2
-TARGET_DEVICES += xunlong_orangepi-zero-plus
-
-define Device/xunlong_orangepi-pc2
+define Device/xunlong_orangepi-zero-plus
DEVICE_VENDOR := Xunlong
- DEVICE_MODEL := Orange Pi PC 2
+ DEVICE_MODEL := Orange Pi Zero Plus
SUNXI_DTS_DIR := allwinner/
SOC := sun50i-h5
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-
-TARGET_DEVICES += xunlong_orangepi-pc2
-
-endif
+TARGET_DEVICES += xunlong_orangepi-zero-plus
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index 3dad8b19b4..cc67f4dd62 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -6,48 +6,54 @@
# See /LICENSE for more information.
#
-ifeq ($(SUBTARGET),cortexa7)
-
-define Device/olimex_a20-olinuxino-lime
- DEVICE_VENDOR := Olimex
- DEVICE_MODEL := A20-OLinuXino-LIME
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi
- SOC := sun7i
+define Device/cubietech_cubieboard2
+ DEVICE_VENDOR := Cubietech
+ DEVICE_MODEL := Cubieboard2
+ DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
+ SOC := sun7i-a20
endef
+TARGET_DEVICES += cubietech_cubieboard2
-TARGET_DEVICES += olimex_a20-olinuxino-lime
-
-
-define Device/olimex_a20-olinuxino-lime2
- DEVICE_VENDOR := Olimex
- DEVICE_MODEL := A20-OLinuXino-LIME2
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
- SOC := sun7i
+define Device/cubietech_cubietruck
+ DEVICE_VENDOR := Cubietech
+ DEVICE_MODEL := Cubietruck
+ DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-brcmfmac
+ SOC := sun7i-a20
endef
+TARGET_DEVICES += cubietech_cubietruck
-TARGET_DEVICES += olimex_a20-olinuxino-lime2
-
-
-define Device/olimex_a20-olinuxino-lime2-emmc
- DEVICE_VENDOR := Olimex
- DEVICE_MODEL := A20-OLinuXino-LIME2
- DEVICE_VARIANT := eMMC
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
- SOC := sun7i
+define Device/friendlyarm_nanopi-m1-plus
+ DEVICE_VENDOR := FriendlyARM
+ DEVICE_MODEL := NanoPi M1 Plus
+ DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
+ kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
+ SOC := sun8i-h3
endef
+TARGET_DEVICES += friendlyarm_nanopi-m1-plus
-TARGET_DEVICES += olimex_a20-olinuxino-lime2-emmc
-
-
-define Device/olimex_a20-olinuxino-micro
- DEVICE_VENDOR := Olimex
- DEVICE_MODEL := A20-OLinuXino-MICRO
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SOC := sun7i
+define Device/friendlyarm_nanopi-neo
+ DEVICE_VENDOR := FriendlyARM
+ DEVICE_MODEL := NanoPi NEO
+ SOC := sun8i-h3
endef
+TARGET_DEVICES += friendlyarm_nanopi-neo
-TARGET_DEVICES += olimex_a20-olinuxino-micro
+define Device/friendlyarm_nanopi-neo-air
+ DEVICE_VENDOR := FriendlyARM
+ DEVICE_MODEL := NanoPi NEO Air
+ DEVICE_PACKAGES := kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
+ kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
+ SOC := sun8i-h3
+endef
+TARGET_DEVICES += friendlyarm_nanopi-neo-air
+define Device/lamobo_lamobo-r1
+ DEVICE_VENDOR := Lamobo
+ DEVICE_MODEL := Lamobo R1
+ DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtl8192cu swconfig wpad-basic
+ SOC := sun7i-a20
+endef
+TARGET_DEVICES += lamobo_lamobo-r1
define Device/lemaker_bananapi
DEVICE_VENDOR := LeMaker
@@ -55,9 +61,15 @@ define Device/lemaker_bananapi
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi
SOC := sun7i-a20
endef
-
TARGET_DEVICES += lemaker_bananapi
+define Device/lemaker_bananapi-m2-ultra
+ DEVICE_VENDOR := LeMaker
+ DEVICE_MODEL := Banana Pi M2 Ultra
+ DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi
+ SOC := sun8i-r40
+endef
+TARGET_DEVICES += lemaker_bananapi-m2-ultra
define Device/lemaker_bananapro
DEVICE_VENDOR := LeMaker
@@ -65,39 +77,16 @@ define Device/lemaker_bananapro
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi kmod-brcmfmac
SOC := sun7i-a20
endef
-
TARGET_DEVICES += lemaker_bananapro
-
-define Device/cubietech_cubieboard2
- DEVICE_VENDOR := Cubietech
- DEVICE_MODEL := Cubieboard2
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SOC := sun7i-a20
-endef
-
-TARGET_DEVICES += cubietech_cubieboard2
-
-
-define Device/cubietech_cubietruck
- DEVICE_VENDOR := Cubietech
- DEVICE_MODEL := Cubietruck
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-brcmfmac
- SOC := sun7i-a20
-endef
-
-TARGET_DEVICES += cubietech_cubietruck
-
-
-define Device/lamobo_lamobo-r1
- DEVICE_VENDOR := Lamobo
- DEVICE_MODEL := Lamobo R1
- DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtl8192cu swconfig wpad-basic
+define Device/linksprite_pcduino3
+ DEVICE_VENDOR := LinkSprite
+ DEVICE_MODEL := pcDuino3
+ DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi \
+ kmod-rtl8xxxu rtl8188eu-firmware
SOC := sun7i-a20
endef
-
-TARGET_DEVICES += lamobo_lamobo-r1
-
+TARGET_DEVICES += linksprite_pcduino3
define Device/mele_m9
DEVICE_VENDOR := Mele
@@ -105,138 +94,102 @@ define Device/mele_m9
DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
SOC := sun6i-a31
endef
-
TARGET_DEVICES += mele_m9
-
-define Device/xunlong_orangepi-zero
- DEVICE_VENDOR := Xunlong
- DEVICE_MODEL := Orange Pi Zero
- DEVICE_PACKAGES:=kmod-rtc-sunxi
- SOC := sun8i-h2-plus
+define Device/olimex_a20-olinuxino-lime
+ DEVICE_VENDOR := Olimex
+ DEVICE_MODEL := A20-OLinuXino-LIME
+ DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi
+ SOC := sun7i
endef
+TARGET_DEVICES += olimex_a20-olinuxino-lime
-TARGET_DEVICES += xunlong_orangepi-zero
-
+define Device/olimex_a20-olinuxino-lime2
+ DEVICE_VENDOR := Olimex
+ DEVICE_MODEL := A20-OLinuXino-LIME2
+ DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
+ SOC := sun7i
+endef
+TARGET_DEVICES += olimex_a20-olinuxino-lime2
-define Device/xunlong_orangepi-r1
- DEVICE_VENDOR := Xunlong
- DEVICE_MODEL := Orange Pi R1
- DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net kmod-usb-net-rtl8152
- SOC := sun8i-h2-plus
+define Device/olimex_a20-olinuxino-lime2-emmc
+ DEVICE_VENDOR := Olimex
+ DEVICE_MODEL := A20-OLinuXino-LIME2
+ DEVICE_VARIANT := eMMC
+ DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
+ SOC := sun7i
endef
+TARGET_DEVICES += olimex_a20-olinuxino-lime2-emmc
-TARGET_DEVICES += xunlong_orangepi-r1
+define Device/olimex_a20-olinuxino-micro
+ DEVICE_VENDOR := Olimex
+ DEVICE_MODEL := A20-OLinuXino-MICRO
+ DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
+ SOC := sun7i
+endef
+TARGET_DEVICES += olimex_a20-olinuxino-micro
define Device/sinovoip_bananapi-m2-plus
DEVICE_VENDOR := Sinovoip
DEVICE_MODEL := Banana Pi M2+
- DEVICE_PACKAGES:=kmod-rtc-sunxi \
- kmod-leds-gpio kmod-ledtrig-heartbeat \
+ DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
kmod-brcmfmac brcmfmac-firmware-43430a0-sdio wpad-basic
SOC := sun8i-h3
endef
-
TARGET_DEVICES += sinovoip_bananapi-m2-plus
-define Device/friendlyarm_nanopi-m1-plus
- DEVICE_VENDOR := FriendlyARM
- DEVICE_MODEL := NanoPi M1 Plus
- DEVICE_PACKAGES:=kmod-rtc-sunxi \
- kmod-leds-gpio kmod-ledtrig-heartbeat \
- kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
- SOC := sun8i-h3
-endef
-
-TARGET_DEVICES += friendlyarm_nanopi-m1-plus
-
-
-define Device/friendlyarm_nanopi-neo
- DEVICE_VENDOR := FriendlyARM
- DEVICE_MODEL := NanoPi NEO
- SOC := sun8i-h3
-endef
-
-TARGET_DEVICES += friendlyarm_nanopi-neo
-
-
-define Device/friendlyarm_nanopi-neo-air
- DEVICE_VENDOR := FriendlyARM
- DEVICE_MODEL := NanoPi NEO Air
- DEVICE_PACKAGES := kmod-rtc-sunxi \
- kmod-leds-gpio kmod-ledtrig-heartbeat \
- kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
- SOC := sun8i-h3
-endef
-
-TARGET_DEVICES += friendlyarm_nanopi-neo-air
-
-
define Device/xunlong_orangepi-one
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi One
DEVICE_PACKAGES:=kmod-rtc-sunxi
SOC := sun8i-h3
endef
-
TARGET_DEVICES += xunlong_orangepi-one
-
define Device/xunlong_orangepi-pc
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi PC
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
SOC := sun8i-h3
endef
-
TARGET_DEVICES += xunlong_orangepi-pc
-
define Device/xunlong_orangepi-pc-plus
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi PC Plus
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
SOC := sun8i-h3
endef
-
TARGET_DEVICES += xunlong_orangepi-pc-plus
-
define Device/xunlong_orangepi-plus
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi Plus
DEVICE_PACKAGES:=kmod-rtc-sunxi
SOC := sun8i-h3
endef
-
TARGET_DEVICES += xunlong_orangepi-plus
+define Device/xunlong_orangepi-r1
+ DEVICE_VENDOR := Xunlong
+ DEVICE_MODEL := Orange Pi R1
+ DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net kmod-usb-net-rtl8152
+ SOC := sun8i-h2-plus
+endef
+TARGET_DEVICES += xunlong_orangepi-r1
+
+define Device/xunlong_orangepi-zero
+ DEVICE_VENDOR := Xunlong
+ DEVICE_MODEL := Orange Pi Zero
+ DEVICE_PACKAGES:=kmod-rtc-sunxi
+ SOC := sun8i-h2-plus
+endef
+TARGET_DEVICES += xunlong_orangepi-zero
+
define Device/xunlong_orangepi-2
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi 2
DEVICE_PACKAGES:=kmod-rtc-sunxi
SOC := sun8i-h3
endef
-
TARGET_DEVICES += xunlong_orangepi-2
-
-
-define Device/linksprite_pcduino3
- DEVICE_VENDOR := LinkSprite
- DEVICE_MODEL := pcDuino3
- DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi kmod-rtl8xxxu rtl8188eu-firmware
- SOC := sun7i-a20
-endef
-
-TARGET_DEVICES += linksprite_pcduino3
-
-define Device/lemaker_bananapi-m2-ultra
- DEVICE_VENDOR := LeMaker
- DEVICE_MODEL := Banana Pi M2 Ultra
- DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi
- SOC := sun8i-r40
-endef
-
-TARGET_DEVICES += lemaker_bananapi-m2-ultra
-
-endif
diff --git a/target/linux/sunxi/image/cortex-a8.mk b/target/linux/sunxi/image/cortex-a8.mk
index fdebfa716c..de10d5d6cc 100644
--- a/target/linux/sunxi/image/cortex-a8.mk
+++ b/target/linux/sunxi/image/cortex-a8.mk
@@ -5,7 +5,31 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-ifeq ($(SUBTARGET),cortexa8)
+
+define Device/cubietech_a10-cubieboard
+ DEVICE_VENDOR := Cubietech
+ DEVICE_MODEL := Cubieboard
+ DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
+ SOC := sun4i
+endef
+TARGET_DEVICES += cubietech_a10-cubieboard
+
+define Device/linksprite_a10-pcduino
+ DEVICE_VENDOR := LinkSprite
+ DEVICE_MODEL := pcDuino
+ DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
+ SOC := sun4i
+endef
+TARGET_DEVICES += linksprite_a10-pcduino
+
+define Device/marsboard_a10-marsboard
+ DEVICE_VENDOR := HAOYU Electronics
+ DEVICE_MODEL := MarsBoard A10
+ DEVICE_PACKAGES:=mod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi \
+ sound-soc-sunxi
+ SOC := sun4i
+endef
+TARGET_DEVICES += marsboard_a10-marsboard
define Device/olimex_a10-olinuxino-lime
DEVICE_VENDOR := Olimex
@@ -13,10 +37,8 @@ define Device/olimex_a10-olinuxino-lime
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
SOC := sun4i
endef
-
TARGET_DEVICES += olimex_a10-olinuxino-lime
-
define Device/olimex_a13-olimex-som
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A13-SOM
@@ -25,47 +47,12 @@ define Device/olimex_a13-olimex-som
SOC := sun5i-a13
SUNXI_DTS := sun5i-a13-olinuxino
endef
-
TARGET_DEVICES += olimex_a13-olimex-som
-
define Device/olimex_a13-olinuxino
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A13-OLinuXino
DEVICE_PACKAGES:=kmod-rtl8192cu
SOC := sun5i
endef
-
TARGET_DEVICES += olimex_a13-olinuxino
-
-
-define Device/cubietech_a10-cubieboard
- DEVICE_VENDOR := Cubietech
- DEVICE_MODEL := Cubieboard
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SOC := sun4i
-endef
-
-TARGET_DEVICES += cubietech_a10-cubieboard
-
-
-define Device/linksprite_a10-pcduino
- DEVICE_VENDOR := LinkSprite
- DEVICE_MODEL := pcDuino
- DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
- SOC := sun4i
-endef
-
-TARGET_DEVICES += linksprite_a10-pcduino
-
-
-define Device/marsboard_a10-marsboard
- DEVICE_VENDOR := HAOYU Electronics
- DEVICE_MODEL := MarsBoard A10
- DEVICE_PACKAGES:=mod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi sound-soc-sunxi
- SOC := sun4i
-endef
-
-TARGET_DEVICES += marsboard_a10-marsboard
-
-endif