aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorRani Hod <rani.hod@gmail.com>2023-04-09 22:47:58 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2023-04-29 22:05:20 +0200
commite4c7703d2a62b8914e4723adae3f67c68a57532c (patch)
tree242200c1e7cfc5a574aeb6fa08051e387078bd5c /target/linux/ramips/image
parent829a50d242287060c749882b7bf9af4c6a4505b4 (diff)
downloadupstream-e4c7703d2a62b8914e4723adae3f67c68a57532c.tar.gz
upstream-e4c7703d2a62b8914e4723adae3f67c68a57532c.tar.bz2
upstream-e4c7703d2a62b8914e4723adae3f67c68a57532c.zip
ramips: add support for D-Link DAP-1620 B1
The DAP-1620 rev B is a wall-plug AC1300 repeater. Specifications: - MT7621AT, 256 MiB RAM, 16 MiB SPI NOR - MT7615DN 2x2 802.11n +2x2 802.11ac (DBDC) - Ethernet: 1 port 10/100/1000 - Status LEDs (1x red+green) - LED RSSI bargraph (2x green, 1x red+green) Installation: - Keep reset button pressed during plug-in - Web Recovery Updater is at 192.168.0.50 - Upload factory.bin, confirm flashing (seems to work best with Chromium-based browsers) Revert to OEM firmware: - tail -c+117 DAP1620B1_FW212B03.bin | \ openssl aes-256-cbc -d -md md5 -out decrypted.bin \ -k 905503a4e0c3cd3c1ce062246de427a68962347e - flash decrypted.bin via D-Link Web Recovery Signed-off-by: Rani Hod <rani.hod@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk18
1 files changed, 17 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 96bfab3fef..c362046b8e 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -7,7 +7,7 @@ include ./common-tp-link.mk
DEFAULT_SOC := mt7621
-DEVICE_VARS += ELECOM_HWNAME LINKSYS_HWNAME
+DEVICE_VARS += ELECOM_HWNAME LINKSYS_HWNAME DLINK_HWID
ifdef CONFIG_LINUX_5_10
DTS_CPPFLAGS += -DDTS_LEGACY
@@ -554,6 +554,22 @@ define Device/cudy_x6
endef
TARGET_DEVICES += cudy_x6
+define Device/dlink_dap-1620-b1
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DAP-1620
+ DEVICE_VARIANT := B1
+ DEVICE_PACKAGES := kmod-mt7615-firmware rssileds
+ DLINK_HWID := MT76XMT7621-RP-PR2475-NA
+ IMAGE_SIZE := 16064k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | \
+ check-size 11009992 | pad-to 11009992 | \
+ append-md5sum-ascii-salted ffff | \
+ append-string $$(DLINK_HWID) | \
+ check-size
+endef
+TARGET_DEVICES += dlink_dap-1620-b1
+
define Device/dlink_dap-x1860-a1
$(Device/dsa-migration)
IMAGE_SIZE := 53248k