aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk18
1 files changed, 17 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 96bfab3fef..c362046b8e 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -7,7 +7,7 @@ include ./common-tp-link.mk
DEFAULT_SOC := mt7621
-DEVICE_VARS += ELECOM_HWNAME LINKSYS_HWNAME
+DEVICE_VARS += ELECOM_HWNAME LINKSYS_HWNAME DLINK_HWID
ifdef CONFIG_LINUX_5_10
DTS_CPPFLAGS += -DDTS_LEGACY
@@ -554,6 +554,22 @@ define Device/cudy_x6
endef
TARGET_DEVICES += cudy_x6
+define Device/dlink_dap-1620-b1
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DAP-1620
+ DEVICE_VARIANT := B1
+ DEVICE_PACKAGES := kmod-mt7615-firmware rssileds
+ DLINK_HWID := MT76XMT7621-RP-PR2475-NA
+ IMAGE_SIZE := 16064k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | \
+ check-size 11009992 | pad-to 11009992 | \
+ append-md5sum-ascii-salted ffff | \
+ append-string $$(DLINK_HWID) | \
+ check-size
+endef
+TARGET_DEVICES += dlink_dap-1620-b1
+
define Device/dlink_dap-x1860-a1
$(Device/dsa-migration)
IMAGE_SIZE := 53248k