aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorThibaut VARENE <hacks@slashdirt.org>2017-01-18 11:34:56 +0100
committerJohn Crispin <john@phrozen.org>2017-01-18 12:06:16 +0100
commit7fb11c8ed2ca47716a2f27e5efed8bcd567cfc98 (patch)
tree36b731ce7a3912ed0faab609a4cf49d60a17c738 /target/linux/ramips/image
parent29d0ac35bdc9cee710b7af174c01a1238f191d13 (diff)
downloadupstream-7fb11c8ed2ca47716a2f27e5efed8bcd567cfc98.tar.gz
upstream-7fb11c8ed2ca47716a2f27e5efed8bcd567cfc98.tar.bz2
upstream-7fb11c8ed2ca47716a2f27e5efed8bcd567cfc98.zip
ramips: add support for Netgear WN3000RPv3
This patch adds support for the Netgear WN3000RPv3 http://www.netgear.com/support/product/wn3000rpv3.aspx Specifications: - SoC: MediaTek MT7620A (580MHz, ramips) - RAM: 32MB DDR - Storage: 8MB NOR SPI flash - Wireless: builtin MT7620A, 2x2:2 with u.FL connectors - Ethernet: 1x100M - Serial: JP1 header, 57600-8N1 - Stock firmware based on OpenWRT Kamikaze Like the EX2700, the bootloader expects a secondary image signature, see https://forum.openwrt.org/viewtopic.php?pid=312577#p312577 This is why the same fakeroot image is used for the WN3000 Signed-off-by: Thibaut VARENE <hacks@slashdirt.org>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 1889bcf708..42e0ab63c2 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -75,6 +75,17 @@ define Device/ex2700
endef
TARGET_DEVICES += ex2700
+define Device/wn3000rpv3
+ DTS := WN3000RPV3
+ BLOCKSIZE := 4k
+ IMAGES += factory.bin
+ KERNEL := $(KERNEL_DTB) | uImage lzma | pad-kernel-ex2700
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+ netgear-header -B WN3000RPv3 -H 29764836+8+0+32+2x2+0
+ DEVICE_TITLE := Netgear WN3000RPv3
+endef
+TARGET_DEVICES += wn3000rpv3
+
define Device/wt3020-4M
DTS := WT3020-4M
BLOCKSIZE := 4k