aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-03-14 02:06:40 +0100
committerDavid Bauer <mail@david-bauer.net>2023-03-15 01:44:29 +0100
commit7dceef5ee554ec4ab5d2dd2ff999f4a60bf2e0f4 (patch)
tree83e0bf171cf1a77b8e447836a55a620eb6ca17e1 /target/linux/ramips/image
parent86be8677b374fb1326ea249e6cb05df458253228 (diff)
downloadupstream-7dceef5ee554ec4ab5d2dd2ff999f4a60bf2e0f4.tar.gz
upstream-7dceef5ee554ec4ab5d2dd2ff999f4a60bf2e0f4.tar.bz2
upstream-7dceef5ee554ec4ab5d2dd2ff999f4a60bf2e0f4.zip
ramips: add support for TP-Link Archer AX23 v1
Hardware -------- CPU: MediaTek MT7621 DAT RAM: 128MB DDR3 (integrated) FLASH: 16MB SPI-NOR () WiFi: MediaTek MT7905 + MT7975 (2.4 / 5 DBDC) 802.11ax SERIAL: 115200 8N1 LEDs - (3V3 - GND - RX - TX) - ETH ports Installation ------------ Upload the factory image using the Web-UI. Web-Recovery ------------ The router supports a HTTP recovery mode by holding the reset-button when powering on. The interface is reachable at 192.168.0.1 and supports installation using the factory image. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index a88f00e677..90b8bba2a5 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2038,6 +2038,18 @@ define Device/totolink_x5000r
endef
TARGET_DEVICES += totolink_x5000r
+define Device/tplink_archer-ax23-v1
+ $(Device/dsa-migration)
+ $(Device/tplink-safeloader)
+ DEVICE_MODEL := Archer AX23
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-mt7915-firmware -uboot-envtools
+ TPLINK_BOARD_ID := ARCHER-AX23-V1
+ KERNEL := $(KERNEL_DTB) | uImage lzma
+ IMAGE_SIZE := 15744k
+endef
+TARGET_DEVICES += tplink_archer-ax23-v1
+
define Device/tplink_archer-a6-v3
$(Device/dsa-migration)
$(Device/tplink-safeloader)