aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7628.mk
diff options
context:
space:
mode:
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>2016-11-06 13:00:38 +0100
committerJohn Crispin <john@phrozen.org>2016-11-08 11:17:10 +0100
commit5f6e94855113b0c37fba57eda4af0b0427457b98 (patch)
tree80cd6965c337769bd84fb7e7d175fde6cff0d397 /target/linux/ramips/image/mt7628.mk
parenta50243ea1f1fe28239a57283ef3a5ec6e8577dfb (diff)
downloadupstream-5f6e94855113b0c37fba57eda4af0b0427457b98.tar.gz
upstream-5f6e94855113b0c37fba57eda4af0b0427457b98.tar.bz2
upstream-5f6e94855113b0c37fba57eda4af0b0427457b98.zip
ramips: Add support for Wavlink WL-WN575A3
This commit adds support for the Wavlink WL-WN575A3, a dual-band wall-plug wireless router with the following specifications: - CPU: MediaTek MT7628AN 580MHz - Flash: 8MB - RAM: 64MB - Ethernet: 2x 10/100 Mbps (switched) - 2.4 GHz: 802.11b/g/n SoC, MIMO 2x2, 20 dBm - 5 GHz: 802.11a/n/ac MT7612E, MIMO 2x2, 20 dBm - Antennas: 4x external (2 per radio), non-detachable - LEDs: 4 programmable + LAN, WAN, POWER - Buttons: reset, WPS Flashing instructions: Factory U-boot launches a TFTP client if WPS button is pressed during power-on. Rename the sysupgrade file and configure a TFTP as follows: - Client (WL-WN575A3) IP: 192.168.10.101 - Server IP: 192.168.10.100 - Filename: firmware.bin Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net>
Diffstat (limited to 'target/linux/ramips/image/mt7628.mk')
-rw-r--r--target/linux/ramips/image/mt7628.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7628.mk b/target/linux/ramips/image/mt7628.mk
index 75fbb3dabd..7a7ddce3c9 100644
--- a/target/linux/ramips/image/mt7628.mk
+++ b/target/linux/ramips/image/mt7628.mk
@@ -19,6 +19,13 @@ define Device/miwifi-nano
endef
TARGET_DEVICES += miwifi-nano
+define Device/wl-wn575a3
+ DTS := WL-WN575A3
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ DEVICE_TITLE := Wavlink WL-WN575A3
+endef
+TARGET_DEVICES += wl-wn575a3
+
define Device/wrtnode2p
DTS := WRTNODE2P
IMAGE_SIZE := $(ralink_default_fw_size_16M)