aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorJiawei Wang <buaawjw@gmail.com>2017-04-20 11:07:26 +0800
committerMathias Kresin <dev@kresin.me>2017-04-25 19:29:59 +0200
commitff258effd508fc75edfb08ba709b333619d3f1e8 (patch)
tree4a053477c418b6d5043e1756a13e92e0458a5995 /target/linux/ramips/image/mt7621.mk
parent187624f759f6ee3ede1697d9cfbc648a92a18ef1 (diff)
downloadupstream-ff258effd508fc75edfb08ba709b333619d3f1e8.tar.gz
upstream-ff258effd508fc75edfb08ba709b333619d3f1e8.tar.bz2
upstream-ff258effd508fc75edfb08ba709b333619d3f1e8.zip
ramips: add support for ZBT-WE1326
Specification: - SoC: MT7621AT, MT7603EN and MT7612EN - Flash: 16 MiB (W25Q128FVSG) - RAM: 512 MiB (EM6GE16EWXD-12H) - Ethernet: 1 x WAN (10/100/1000Mbps) and 4 x LAN (10/100/1000 Mbps) - Others: USB 2.0, micro SD slot, reset button and 8 x LEDs Issues: - Two LEDs for 2.4 GHz and 5 GHz Wi-Fi do not work, can't find GPIOs. - The pwr LED is not GPIO controllable How to install: - The original firmware is OpenWrt, so both LuCI or sysupgrade can be used. - Do not keep settings, for sysupgrade please use the -n option. Signed-off-by: Jiawei Wang <buaawjw@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index feda0f12f7..0e418fe47e 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -245,6 +245,14 @@ define Device/wsr-600
endef
TARGET_DEVICES += wsr-600
+define Device/zbt-we1326
+ DTS := ZBT-WE1326
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := ZBT WE1326
+ DEVICE_PACKAGES := kmod-usb3 kmod-sdhci-mt7620
+endef
+TARGET_DEVICES += zbt-we1326
+
define Device/zbt-wg2626
DTS := ZBT-WG2626
IMAGE_SIZE := $(ralink_default_fw_size_16M)