aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJiawei Wang <buaawjw@gmail.com>2017-04-20 11:07:26 +0800
committerMathias Kresin <dev@kresin.me>2017-04-25 19:29:59 +0200
commitff258effd508fc75edfb08ba709b333619d3f1e8 (patch)
tree4a053477c418b6d5043e1756a13e92e0458a5995 /target/linux
parent187624f759f6ee3ede1697d9cfbc648a92a18ef1 (diff)
downloadupstream-ff258effd508fc75edfb08ba709b333619d3f1e8.tar.gz
upstream-ff258effd508fc75edfb08ba709b333619d3f1e8.tar.bz2
upstream-ff258effd508fc75edfb08ba709b333619d3f1e8.zip
ramips: add support for ZBT-WE1326
Specification: - SoC: MT7621AT, MT7603EN and MT7612EN - Flash: 16 MiB (W25Q128FVSG) - RAM: 512 MiB (EM6GE16EWXD-12H) - Ethernet: 1 x WAN (10/100/1000Mbps) and 4 x LAN (10/100/1000 Mbps) - Others: USB 2.0, micro SD slot, reset button and 8 x LEDs Issues: - Two LEDs for 2.4 GHz and 5 GHz Wi-Fi do not work, can't find GPIOs. - The pwr LED is not GPIO controllable How to install: - The original firmware is OpenWrt, so both LuCI or sysupgrade can be used. - Do not keep settings, for sysupgrade please use the -n option. Signed-off-by: Jiawei Wang <buaawjw@gmail.com>
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/ZBT-WE1326.dts107
-rw-r--r--target/linux/ramips/image/mt7621.mk8
5 files changed, 120 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index ecfa8a66e6..1abe13991f 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -112,6 +112,7 @@ ramips_setup_interfaces()
y1|\
youku-yk1|\
zbt-ape522ii|\
+ zbt-we1326|\
zbt-we826|\
zbt-wg2626|\
zbt-wg3526|\
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index eec961284a..61f8a70719 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -649,6 +649,9 @@ ramips_board_detect() {
*"ZBT-WA05")
name="zbt-wa05"
;;
+ *"ZBT-WE1326")
+ name="zbt-we1326"
+ ;;
*"ZBT-WE2026")
name="zbt-we2026"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 036e19afe3..ae5a07b0b4 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -192,6 +192,7 @@ platform_check_image() {
zbt-ape522ii|\
zbt-cpe102|\
zbt-wa05|\
+ zbt-we1326|\
zbt-we2026|\
zbt-we826|\
zbt-wg2626|\
diff --git a/target/linux/ramips/dts/ZBT-WE1326.dts b/target/linux/ramips/dts/ZBT-WE1326.dts
new file mode 100644
index 0000000000..0dc2c77a39
--- /dev/null
+++ b/target/linux/ramips/dts/ZBT-WE1326.dts
@@ -0,0 +1,107 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ model = "ZBT-WE1326";
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x1c000000>, <0x20000000 0x4000000>;
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "wdt";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <10000000>;
+ m25p,chunked-io = <32>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0xfb0000>;
+ };
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0xe000>;
+};
+
+&pcie {
+ status = "okay";
+
+ pcie0 {
+ mt76@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ device_type = "pci";
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+ };
+
+ pcie1 {
+ mt76@1,0 {
+ reg = <0x0000 0 0 0 0>;
+ device_type = "pci";
+ mediatek,mtd-eeprom = <&factory 0x0000>;
+ ieee80211-freq-limit = <2400000 2500000>;
+ };
+ };
+};
+
+&sdhci {
+ status = "okay";
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index feda0f12f7..0e418fe47e 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -245,6 +245,14 @@ define Device/wsr-600
endef
TARGET_DEVICES += wsr-600
+define Device/zbt-we1326
+ DTS := ZBT-WE1326
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := ZBT WE1326
+ DEVICE_PACKAGES := kmod-usb3 kmod-sdhci-mt7620
+endef
+TARGET_DEVICES += zbt-we1326
+
define Device/zbt-wg2626
DTS := ZBT-WG2626
IMAGE_SIZE := $(ralink_default_fw_size_16M)