aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorAndrew Pikler <andrew.pikler@gmail.com>2020-10-05 17:16:44 +0300
committerPetr Štetiar <ynezz@true.cz>2020-12-22 19:11:50 +0100
commit28262f815e4d0fe5302babc696ed5ce518b33759 (patch)
tree2d0cff9a36ae80ae550d363c0f2ff63dc9b9eeee /target/linux/ramips/image/mt7621.mk
parent40437b18f41918d7bbbb7da986b8842bf82f9ff0 (diff)
downloadupstream-28262f815e4d0fe5302babc696ed5ce518b33759.tar.gz
upstream-28262f815e4d0fe5302babc696ed5ce518b33759.tar.bz2
upstream-28262f815e4d0fe5302babc696ed5ce518b33759.zip
ramips: add support for D-Link DIR-882 R1
Specifications: - SoC: MediaTek MT7621AT - RAM: 128 MB (DDR3) - Flash: 16 MB (SPI NOR) - WiFi: MediaTek MT7615N (x2) - Switch: 1 WAN, 4 LAN (Gigabit) - Ports: 1 USB 2.0, 1 USB 3.0 - Buttons: Reset, WiFi Toggle, WPS - LEDs: Power, Internet, WiFi 2.4G WiFi 5G, USB 2.0, USB 3.0 The R1 revision is identical to the A1 revision except - No Config2 Parition, therefore - factory partition resized to 64k from 128K - Firmware partition offset is 0x50000 not 0x60000 - Firmware partitions size increased by 64K - Firmware partition type is "denx,uimage", not "sge,uimage" - Padding of image creation "uimage-padhdr 96" removed Installation: - Older firmware versions: put the factory image on a USB stick, turn on the telnet console, and flash using the following cmd "fw_updater Linux /mnt/usb_X_X/firmware.bin" - D-Link FailsafeUI: Power down the router, press and hold the reset button, then re-plug it. Keep the reset button pressed until the internet LED stops flashing, then jack into any lan port and manually assign a static IP address in 192.168.0.0/24 other than 192.168.0.0 (e.g. 192.168.0.2) and go to http://192.168.0.1 Flash with the factory image. Signed-off-by: Andrew Pikler <andrew.pikler@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index cc0eb1d279..cf81a862ff 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -235,6 +235,17 @@ define Device/dlink_dir-8xx-a1
check-size
endef
+define Device/dlink_dir-8xx-r1
+ $(Device/dsa-migration)
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := D-Link
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware
+ KERNEL_INITRAMFS := $$(KERNEL)
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs |\
+ pad-rootfs | append-metadata | check-size
+endef
+
define Device/dlink_dir-xx60-a1
$(Device/dsa-migration)
BLOCKSIZE := 128k
@@ -312,6 +323,17 @@ define Device/dlink_dir-882-a1
endef
TARGET_DEVICES += dlink_dir-882-a1
+define Device/dlink_dir-882-r1
+ $(Device/dlink_dir-8xx-r1)
+ DEVICE_MODEL := DIR-882
+ DEVICE_VARIANT := R1
+ DEVICE_PACKAGES += kmod-usb3 kmod-usb-ledtrig-usbport
+ IMAGE/factory.bin := append-kernel | append-rootfs | check-size | \
+ sign-dlink-ru 57c5375741c30ca9ebcb36713db4ba51 \
+ ab0dff19af8842cdb70a86b4b68d23f7
+endef
+TARGET_DEVICES += dlink_dir-882-r1
+
define Device/d-team_newifi-d2
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)