aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-12-01 07:37:03 +0100
committerMathias Kresin <dev@kresin.me>2016-12-24 10:03:38 +0100
commitd2b6bf141662429d542b23e9e8f44245a77710a5 (patch)
treece3935a111b0f358e3a6814ed88aeaa460141a59 /target/linux/ramips/image/mt7620.mk
parentae3ac76e565724e188138dafe38ebeed122e2cf8 (diff)
downloadupstream-d2b6bf141662429d542b23e9e8f44245a77710a5.tar.gz
upstream-d2b6bf141662429d542b23e9e8f44245a77710a5.tar.bz2
upstream-d2b6bf141662429d542b23e9e8f44245a77710a5.zip
ramips: fix image validation errors
The name from the Device define will be used in the metadata. Due to typos/different spelling, this name might not match the one exported in /lib/ramips.sh. Fix all name mismatches which were found by checking if the name used in the metadata exists in /lib/ramips.sh. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 24b78cb97b..a8c7f5c8c7 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -43,6 +43,7 @@ endef
define Device/ArcherC20i
DTS := ArcherC20i
+ SUPPORTED_DEVICES := c20i
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC20i -c
IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC20i -j | append-metadata
@@ -52,6 +53,7 @@ TARGET_DEVICES += ArcherC20i
define Device/ArcherC50
DTS := ArcherC50
+ SUPPORTED_DEVICES := c50
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC50 -c
IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC50 -j | append-metadata